Skip to content

← Actionable
High, CVSS 7.5amended

PyMongo: PYTHON-5996 Heap out-of-bounds write via signed size overflow in BSON document encoding

CVE-2026-96749GHSA-v4x9-3549-crwv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pymongo 4.18.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pymongo

    Affected
    < 4.18.2
    Fixed in
    4.18.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.5 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-96749: 0.19% estimated exploitation activity in the next 30 days; percentile 8.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An integer overflow in the BSON document encoding component of the MongoDB Python Driver's bundled native extension may occur when a single document is built from an unusually large amount of caller-supplied data. Size arithmetic is performed in a signed 32-bit type, and the guard meant to catch the overflow is written in a form whose behavior is not defined by the C language standard. A party with no privileges who can place a very large value into data that an application encodes may, depending on how the native extension was built, cause a write outside the bounds of an allocated buffer inside the application's own process.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-v4x9-3549-crwv

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-v4x9-3549-crwv

  4. Revision 1 · created ·

    Published from ghsa record GHSA-v4x9-3549-crwv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-96749

Advisory: PyMongo: PYTHON-5996 Heap out-of-bounds write via signed size overflow in BSON document encoding
IDs: CVE-2026-96749, GHSA-v4x9-3549-crwv
Record: https://patchnext.com/advisories/cve-2026-96749 (revision 4, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pymongo 4.18.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pymongo: affected < 4.18.2; fixed in 4.18.2

## Suggested inspection (read-only)
- `python -m pip show pymongo`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pymongo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v4x9-3549-crwv (GitHub-reviewed advisory GHSA-v4x9-3549-crwv lists affected ranges: PyPI pymongo >=0 <4.18.2)
- Verified: https://osv.dev/vulnerability/GHSA-v4x9-3549-crwv (OSV record GHSA-v4x9-3549-crwv lists affected ranges: PyPI pymongo >=0 <4.18.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…