Pillow multi-frame loaders can reuse stale native image storage after mode transitions
CVE-2026-96639GHSA-v9pv-5gc8-w2m6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami pillow
- Affected
- >= 11.0.0, < 13.0.0
- Fixed in
- 13.0.0
PyPI pillow
- Affected
- >= 11.0.0, < 13.0.0
- Fixed in
- 13.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v9pv-5gc8-w2m6 lists affected ranges: PyPI pillow >=11.0.0 <13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v9pv-5gc8-w2m6 lists affected ranges: PyPI pillow >=11.0.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-4339 lists affected ranges: PyPI pillow >=11.0.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-pillow-2026-96639 lists affected ranges: Bitnami pillow >=11.0.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-96639: 0.66% estimated exploitation activity in the next 30 days; percentile 51.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Pillow multi-frame image loaders can retain native `ImagingCore` storage allocated for one frame while changing the Python-side image `mode` and decoder tiles for a later frame. If frame 0 allocates storage for a narrow mode such as `L`, and a later frame of the same dimensions switches to a wider mode such as `RGB` or `CMYK`, Pillow may decode wider pixels into the stale narrow native buffer. This causes native out-of-bounds writes and process crashes. In the MPO/JPEG path, I also demonstrated command execution in matching Python/Pillow runtime profiles through Pillow's documented `ImageSequence.Iterator` + `frame.load()` path.
Details The root cause appears to be that `ImageFile.load_prepare()` only reallocates native storage when `_im is None`. It does not verify that the retained native `ImagingCore` storage still matches `self.mode` and `self.size`. Several multi-frame `seek()` / `_open()` paths can update `self._mode` and decoder tiles for a later frame without…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 8 · amended ·
Amended from osv record BIT-pillow-2026-96639
- Revision 7 · amended ·
Amended from osv record PYSEC-2026-4339
- Revision 6 · amended ·
Amended from osv record GHSA-v9pv-5gc8-w2m6
- Revision 5 · amended ·
Amended from osv record PYSEC-2026-4339
- Revision 4 · amended ·
Amended from osv record GHSA-v9pv-5gc8-w2m6
- Revision 3 · amended ·
Amended from ghsa record GHSA-v9pv-5gc8-w2m6
- Revision 2 · amended ·
Amended from osv record GHSA-v9pv-5gc8-w2m6
- Revision 1 · created ·
Published from ghsa record GHSA-v9pv-5gc8-w2m6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-96639 Advisory: Pillow multi-frame loaders can reuse stale native image storage after mode transitions IDs: CVE-2026-96639, GHSA-v9pv-5gc8-w2m6 Record: https://patchnext.com/advisories/cve-2026-96639 (revision 8, source checked 30 Oct 2026, 07:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami pillow: affected >= 11.0.0, < 13.0.0; fixed in 13.0.0 - PyPI pillow: affected >= 11.0.0, < 13.0.0; fixed in 13.0.0 ## Suggested inspection (read-only) - Bitnami pillow: check the installed version with your package manager. - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v9pv-5gc8-w2m6 (GitHub-reviewed advisory GHSA-v9pv-5gc8-w2m6 lists affected ranges: PyPI pillow >=11.0.0 <13.0.0) - Verified: https://osv.dev/vulnerability/GHSA-v9pv-5gc8-w2m6 (OSV record GHSA-v9pv-5gc8-w2m6 lists affected ranges: PyPI pillow >=11.0.0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-4339 (OSV record PYSEC-2026-4339 lists affected ranges: PyPI pillow >=11.0.0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-pillow-2026-96639 (OSV record BIT-pillow-2026-96639 lists affected ranges: Bitnami pillow >=11.0.0 <13.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…