Pillow: BMP RLE decoder memory-amplification DoS via unbounded delta escape / absolute mode
CVE-2026-96638GHSA-24rc-8hj2-v98c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami pillow
- Affected
- >= 9.1.0, < 13.0.0
- Fixed in
- 13.0.0
PyPI pillow
- Affected
- >= 9.1.0, < 13.0.0
- Fixed in
- 13.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-24rc-8hj2-v98c lists affected ranges: PyPI pillow >=9.1.0 <13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-24rc-8hj2-v98c lists affected ranges: PyPI pillow >=9.1.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-pillow-2026-96638 lists affected ranges: Bitnami pillow >=9.1.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-96638: 0.34% estimated exploitation activity in the next 30 days; percentile 28.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary BmpRleDecoder can be forced to allocate gigabytes of memory from a kilobyte-sized crafted BMP file via unbounded growth in the delta escape and absolute mode branches.
Affected versions All versions up to and including current HEAD (v13.0.0.dev0, commit e7a7ea84)
Root cause BmpRleDecoder.decode() (BmpImagePlugin.py:327-395) builds a Python bytearray `data` with dest_length = xsize*ysize, looping `while len(data) up to ~255*xsize bytes in ONE iteration. - absolute mode (line 385): data += bytes_read (up to 255). Because a single delta can push len(data) to ~256 * (row size), a tiny RLE stream combined with a large-but-legal xsize (xsize*ysize just under MAX_IMAGE_PIXELS, ~89M) yields a multi-GB `data` bytearray (then copied again by bytes(data) and set_as_raw). No heap OOB (bytearray/set_as_raw are bounds-safe), but a severe memory-amplification DoS: the attacker file stays tiny.
Reproduction Python 3.13, Pillow HEAD e7a7ea84 Attached: pillow_poc_bmp_rle_dos.py A…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record BIT-pillow-2026-96638
- Revision 4 · amended ·
Amended from osv record GHSA-24rc-8hj2-v98c
- Revision 3 · amended ·
Amended from ghsa record GHSA-24rc-8hj2-v98c
- Revision 2 · amended ·
Amended from osv record GHSA-24rc-8hj2-v98c
- Revision 1 · created ·
Published from ghsa record GHSA-24rc-8hj2-v98c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-96638 Advisory: Pillow: BMP RLE decoder memory-amplification DoS via unbounded delta escape / absolute mode IDs: CVE-2026-96638, GHSA-24rc-8hj2-v98c Record: https://patchnext.com/advisories/cve-2026-96638 (revision 5, source checked 30 Oct 2026, 07:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami pillow: affected >= 9.1.0, < 13.0.0; fixed in 13.0.0 - PyPI pillow: affected >= 9.1.0, < 13.0.0; fixed in 13.0.0 ## Suggested inspection (read-only) - Bitnami pillow: check the installed version with your package manager. - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-24rc-8hj2-v98c (GitHub-reviewed advisory GHSA-24rc-8hj2-v98c lists affected ranges: PyPI pillow >=9.1.0 <13.0.0) - Verified: https://osv.dev/vulnerability/GHSA-24rc-8hj2-v98c (OSV record GHSA-24rc-8hj2-v98c lists affected ranges: PyPI pillow >=9.1.0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-pillow-2026-96638 (OSV record BIT-pillow-2026-96638 lists affected ranges: Bitnami pillow >=9.1.0 <13.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…