Pillow: Decompression bomb check bypass in SpiderImagePlugin.seek() leads to unbounded allocation DoS
CVE-2026-96637GHSA-g842-9rc4-69pw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami pillow
- Affected
- < 13.0.0
- Fixed in
- 13.0.0
PyPI pillow
- Affected
- < 13.0.0
- Fixed in
- 13.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g842-9rc4-69pw lists affected ranges: PyPI pillow >=0 <13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g842-9rc4-69pw lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-4338 lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-pillow-2026-96637 lists affected ranges: Bitnami pillow >=0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-96637: 0.37% estimated exploitation activity in the next 30 days; percentile 31.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary SpiderImagePlugin's seek() bypasses the decompression bomb check, allowing a tiny ( DecompressionBombWarning fires correctly. - BYPASS: Image.open(stack, frame0=1x1) passes; im.seek(1) sets size (100,100) with NO DecompressionBombWarning/Error -> the check is bypassed. Real-world impact: a large frame-1 nsam/nrow (e.g. 40000x40000) causes im.load() to allocate ~6.4 GB (mode F) with the bomb check fully bypassed, from a file under 1 KB.
Suggested fix Call Image._decompression_bomb_check(self.size) at the end of SpiderImageFile._open() (or in seek() after _open()), mirroring GifImagePlugin / TiffImagePlugin. Optionally validate nsam/nrow are positive and sane in _open(). Credit: Yazan Balawneh - CyStack Security Team pillow_poc_spider_bomb.py
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 10 · amended ·
Amended from osv record BIT-pillow-2026-96637
- Revision 9 · amended ·
Amended from osv record PYSEC-2026-4338
- Revision 8 · amended ·
Amended from osv record GHSA-g842-9rc4-69pw
- Revision 7 · amended ·
Amended from osv record PYSEC-2026-4338
- Revision 6 · amended ·
Amended from osv record GHSA-g842-9rc4-69pw
- Revision 5 · amended ·
Amended from ghsa record GHSA-g842-9rc4-69pw
- Revision 4 · amended ·
Amended from ghsa record GHSA-g842-9rc4-69pw
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-g842-9rc4-69pw
- Revision 1 · created ·
Published from ghsa record GHSA-g842-9rc4-69pw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-96637 Advisory: Pillow: Decompression bomb check bypass in SpiderImagePlugin.seek() leads to unbounded allocation DoS IDs: CVE-2026-96637, GHSA-g842-9rc4-69pw Record: https://patchnext.com/advisories/cve-2026-96637 (revision 10, source checked 30 Oct 2026, 07:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami pillow: affected < 13.0.0; fixed in 13.0.0 - PyPI pillow: affected < 13.0.0; fixed in 13.0.0 ## Suggested inspection (read-only) - Bitnami pillow: check the installed version with your package manager. - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g842-9rc4-69pw (GitHub-reviewed advisory GHSA-g842-9rc4-69pw lists affected ranges: PyPI pillow >=0 <13.0.0) - Verified: https://osv.dev/vulnerability/GHSA-g842-9rc4-69pw (OSV record GHSA-g842-9rc4-69pw lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-4338 (OSV record PYSEC-2026-4338 lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-pillow-2026-96637 (OSV record BIT-pillow-2026-96637 lists affected ranges: Bitnami pillow >=0 <13.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…