Pillow: Decompression-bomb protection bypass via multi-frame seek() in MPO and DCX (MpoImageFile.seek / DcxImageFile.seek)
CVE-2026-96636GHSA-p8hx-v2p6-rp84
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami pillow
- Affected
- < 13.0.0
- Fixed in
- 13.0.0
PyPI pillow
- Affected
- < 13.0.0
- Fixed in
- 13.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p8hx-v2p6-rp84 lists affected ranges: PyPI pillow >=0 <13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p8hx-v2p6-rp84 lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-4337 lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-pillow-2026-96636 lists affected ranges: Bitnami pillow >=0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-96636: 0.34% estimated exploitation activity in the next 30 days; percentile 28.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Pillow's decompression-bomb protection (`Image._decompression_bomb_check`, gated by `Image.MAX_IMAGE_PIXELS`) is enforced only on the first frame, inside `Image.open()`. For multi-frame formats, `seek()` re-parses the target frame's header and resets `self._size`. `GifImagePlugin` and `TiffImagePlugin` re-run the bomb check on `seek()`, but `MpoImageFile.seek()` and `DcxImageFile.seek()` do not. A crafted MPO or DCX whose first frame is tiny (passing the check) but whose later frame declares enormous dimensions therefore bypasses the protection: loading that frame decodes an over-limit image and commits large amounts of memory — a denial of service (memory exhaustion / OOM). Same class as the recently assigned CVE-2026-55379 (BdfFontFile), CVE-2026-55380 (GdImageFile) and CVE-2026-40192 (FITS GZIP).
Details `Image.open()` → `_open_core()` runs `_decompression_bomb_check(im.size)` once, on the frame present at open time. Both vulnerable `seek()` methods…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 8 · amended ·
Amended from osv record BIT-pillow-2026-96636
- Revision 7 · amended ·
Amended from osv record PYSEC-2026-4337
- Revision 6 · amended ·
Amended from osv record GHSA-p8hx-v2p6-rp84
- Revision 5 · amended ·
Amended from osv record PYSEC-2026-4337
- Revision 4 · amended ·
Amended from osv record GHSA-p8hx-v2p6-rp84
- Revision 3 · amended ·
Amended from ghsa record GHSA-p8hx-v2p6-rp84
- Revision 2 · amended ·
Amended from osv record GHSA-p8hx-v2p6-rp84
- Revision 1 · created ·
Published from ghsa record GHSA-p8hx-v2p6-rp84
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-96636 Advisory: Pillow: Decompression-bomb protection bypass via multi-frame seek() in MPO and DCX (MpoImageFile.seek / DcxImageFile.seek) IDs: CVE-2026-96636, GHSA-p8hx-v2p6-rp84 Record: https://patchnext.com/advisories/cve-2026-96636 (revision 8, source checked 30 Oct 2026, 07:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami pillow: affected < 13.0.0; fixed in 13.0.0 - PyPI pillow: affected < 13.0.0; fixed in 13.0.0 ## Suggested inspection (read-only) - Bitnami pillow: check the installed version with your package manager. - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p8hx-v2p6-rp84 (GitHub-reviewed advisory GHSA-p8hx-v2p6-rp84 lists affected ranges: PyPI pillow >=0 <13.0.0) - Verified: https://osv.dev/vulnerability/GHSA-p8hx-v2p6-rp84 (OSV record GHSA-p8hx-v2p6-rp84 lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-4337 (OSV record PYSEC-2026-4337 lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-pillow-2026-96636 (OSV record BIT-pillow-2026-96636 lists affected ranges: Bitnami pillow >=0 <13.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…