Skip to content

← Actionable
High, CVSS 8.2amended

AdminNeo Vulnerable to XSS via Rogue MySQL Server Version String (CSP Nonce Bypass)

CVE-2026-96632GHSA-rx7m-wxwq-vxr9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (adminneo-org/adminneo 5.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary AdminNeo inserts the database server's version string into a ` ` tag that carries a valid CSP nonce, without any sanitization. A rogue database server can return a crafted version string that breaks out of the JavaScript context and executes arbitrary code. Because the script tag already has a valid nonce, the browser's Content Security Policy does not block execution. No authentication is required when combined with Login CSRF. Originally reported in Adminer: https://github.com/vrana/adminer/security/advisories/GHSA-h6jr-7pr6-grgj

Prerequisites - Target runs AdminNeo - Attacker controls a reachable MySQL server (a 80-line Python script)

Root Cause `admin/core/Admin.php`, lines 1285-1286: ```php echo script("let autocompletion;\nwindow.addEventListener('DOMContentLoaded', () => { initSyntaxHighlighting('" . Connection::get()->getVersion() . "', '" . Connection::get()->getFlavor() . "', autocompletion); });"); ``` `script()` wraps the output in ` `. Return value of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-rx7m-wxwq-vxr9

  2. Revision 1 · created ·

    Published from ghsa record GHSA-rx7m-wxwq-vxr9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-96632

Advisory: AdminNeo Vulnerable to XSS via Rogue MySQL Server Version String (CSP Nonce Bypass)
IDs: CVE-2026-96632, GHSA-rx7m-wxwq-vxr9
Record: https://patchnext.com/advisories/cve-2026-96632 (revision 2, source checked 31 Oct 2026, 06:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: adminneo-org/adminneo 5.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist adminneo-org/adminneo: affected < 5.5.1; fixed in 5.5.1

## Suggested inspection (read-only)
- Packagist adminneo-org/adminneo: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on adminneo-org/adminneo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rx7m-wxwq-vxr9 (GitHub-reviewed advisory GHSA-rx7m-wxwq-vxr9 lists affected ranges: Packagist adminneo-org/adminneo >=0 <5.5.1)
- Verified: https://osv.dev/vulnerability/GHSA-rx7m-wxwq-vxr9 (OSV record GHSA-rx7m-wxwq-vxr9 lists affected ranges: Packagist adminneo-org/adminneo >=0 <5.5.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…