Skip to content

← Actionable
High, CVSS 8.2amended

AdminNeo has Cookie Attribute Injection via Unsanitized X-Forwarded-Prefix in Set-Cookie Headers

CVE-2026-96631GHSA-79wv-8rh2-9vp2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (adminneo-org/adminneo 5.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary AdminNeo versions 4.6.0 through at least 5.5.0 are vulnerable to cookie attribute injection via the `X-Forwarded-Prefix` HTTP header. An attacker who can influence this header (e.g., through a reverse proxy that forwards it from clients, an attacker-controlled upstream proxy, or a man-in-the-middle position) can inject arbitrary cookie attributes including `Domain`, `Path`, `Secure`, and `SameSite` into all `Set-Cookie` response headers emitted by AdminNeo. This allows an attacker to expand the cookie scope to an attacker-controlled domain (e.g., `Domain=.evil.com`), causing the victim's browser to send AdminNeo's `neo_sid` (session ID) and `neo_key` (database password encryption key) cookies to the attacker's server on subsequent requests. Originally reported by @retkoussa in Adminer: https://github.com/vrana/adminer/security/advisories/GHSA-c533-9qwm-8w5h

Vulnerable Code Root cause 1 - Unsanitized header prepended to `REQUEST_URI`…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-79wv-8rh2-9vp2

  2. Revision 1 · created ·

    Published from ghsa record GHSA-79wv-8rh2-9vp2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-96631

Advisory: AdminNeo has Cookie Attribute Injection via Unsanitized X-Forwarded-Prefix in Set-Cookie Headers
IDs: CVE-2026-96631, GHSA-79wv-8rh2-9vp2
Record: https://patchnext.com/advisories/cve-2026-96631 (revision 2, source checked 31 Oct 2026, 06:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: adminneo-org/adminneo 5.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist adminneo-org/adminneo: affected >= 4.6.0, < 5.5.1; fixed in 5.5.1

## Suggested inspection (read-only)
- Packagist adminneo-org/adminneo: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on adminneo-org/adminneo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-79wv-8rh2-9vp2 (GitHub-reviewed advisory GHSA-79wv-8rh2-9vp2 lists affected ranges: Packagist adminneo-org/adminneo >=4.6.0 <5.5.1)
- Verified: https://osv.dev/vulnerability/GHSA-79wv-8rh2-9vp2 (OSV record GHSA-79wv-8rh2-9vp2 lists affected ranges: Packagist adminneo-org/adminneo >=4.6.0 <5.5.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…