Arcane: Environment access token bypasses the admin-required authorization gate on /api/debug/pprof
CVE-2026-96628GHSA-mp22-58ff-6fhr
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/getarcaneapp/arcane/backend/v2
- Affected
- < 2.11.0
- Fixed in
- 2.11.0
Go github.com/getarcaneapp/arcane/backend
- Affected
- every version
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6806 lists affected ranges: Go github.com/getarcaneapp/arcane/backend >=0; Go github.com/getarcaneapp/arcane/backend/v2 >=0 <2.11.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mp22-58ff-6fhr lists affected ranges: Go github.com/getarcaneapp/arcane/backend/v2 >=0 <2.11.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mp22-58ff-6fhr lists affected ranges: Go github.com/getarcaneapp/arcane/backend/v2 >=0 <2.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-96628: 0.20% estimated exploitation activity in the next 30 days; percentile 10.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Arcane v2.10.2 contains an authorization inconsistency in AuthMiddleware.managerAuth. When a request supplies a valid environment access token through the X-Arcane-Agent-Token header, managerAuth resolves the associated environment, installs an environment-scoped permission set, and immediately calls next(c). This occurs before the middleware evaluates the AdminRequired option and verifies that the caller is a global administrator. As a result, an environment-scoped access token can access routes protected with WithAdminRequired(), despite the corresponding EnvironmentPermissionSet intentionally containing no global or sudo permissions. In v2.10.2, the affected admin-only surface is the manager's Go pprof diagnostic interface under: /api/debug/pprof/ This exposes diagnostic and runtime profiling information that the application explicitly intends to restrict to global administrators. The issue is an incorrect authorization vulnerability (CWE-863). Details 1. Environment…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mp22-58ff-6fhr
- Revision 2 · amended ·
Amended from osv record GO-2026-6806
- Revision 1 · created ·
Published from osv record GHSA-mp22-58ff-6fhr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-96628 Advisory: Arcane: Environment access token bypasses the admin-required authorization gate on `/api/debug/pprof` IDs: CVE-2026-96628, GHSA-mp22-58ff-6fhr Record: https://patchnext.com/advisories/cve-2026-96628 (revision 3, source checked 26 Oct 2026, 15:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/getarcaneapp/arcane/backend/v2 2.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/getarcaneapp/arcane/backend/v2: affected < 2.11.0; fixed in 2.11.0 - Go github.com/getarcaneapp/arcane/backend: affected every version ## Suggested inspection (read-only) - Go github.com/getarcaneapp/arcane/backend/v2: check the installed version with your package manager. - Go github.com/getarcaneapp/arcane/backend: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/getarcaneapp/arcane/backend/v2, github.com/getarcaneapp/arcane/backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6806 (OSV record GO-2026-6806 lists affected ranges: Go github.com/getarcaneapp/arcane/backend >=0; Go github.com/getarcaneapp/arcane/backend/v2 >=0 <2.11.0 (fixed)) - Verified: https://osv.dev/vulnerability/GHSA-mp22-58ff-6fhr (OSV record GHSA-mp22-58ff-6fhr lists affected ranges: Go github.com/getarcaneapp/arcane/backend/v2 >=0 <2.11.0 (fixed)) - Verified: https://github.com/advisories/GHSA-mp22-58ff-6fhr (GitHub-reviewed advisory GHSA-mp22-58ff-6fhr lists affected ranges: Go github.com/getarcaneapp/arcane/backend/v2 >=0 <2.11.0) Commands are suggestions: review each one before running it.
Loading voting…