Skip to content

← Actionable
Critical, CVSS 9.2amended

Claude Agent SDK: Argument Injection via resume Option Allows Arbitrary Command Execution

CVE-2026-96620GHSA-h4mw-j7qp-8mwm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (claude-agent-sdk 0.2.121), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-96620: 0.70% estimated exploitation activity in the next 30 days; percentile 53.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Claude Agent SDK for Python passed the resume option to the Claude CLI without validation, allowing a value beginning with - to be interpreted as a separate CLI flag. An attacker who controlled the resume value could inject an --mcp-config flag defining a stdio MCP server, resulting in arbitrary command execution at CLI startup that bypassed the SDK's permission controls. Exploitation required an application to pass untrusted input as the session ID to resume. Users are advised to update to the latest version of the claude-agent-sdk package. Thank you to hackerone.com/moamenmahmood for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-h4mw-j7qp-8mwm

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-h4mw-j7qp-8mwm

  4. Revision 1 · created ·

    Published from ghsa record GHSA-h4mw-j7qp-8mwm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-96620

Advisory: Claude Agent SDK: Argument Injection via resume Option Allows Arbitrary Command Execution
IDs: CVE-2026-96620, GHSA-h4mw-j7qp-8mwm
Record: https://patchnext.com/advisories/cve-2026-96620 (revision 4, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: claude-agent-sdk 0.2.121. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI claude-agent-sdk: affected < 0.2.121; fixed in 0.2.121

## Suggested inspection (read-only)
- `python -m pip show claude-agent-sdk`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on claude-agent-sdk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h4mw-j7qp-8mwm (GitHub-reviewed advisory GHSA-h4mw-j7qp-8mwm lists affected ranges: PyPI claude-agent-sdk >=0 <0.2.121)
- Verified: https://osv.dev/vulnerability/GHSA-h4mw-j7qp-8mwm (OSV record GHSA-h4mw-j7qp-8mwm lists affected ranges: PyPI claude-agent-sdk >=0 <0.2.121 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…