Microsoft Security Advisory CVE-2026-96230 - ASP.NET Core Remote Code Execution Vulnerability
CVE-2026-96230GHSA-qjpx-jqm5-h2c4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.aspnetcore.components.webassembly.server 11.0.0-rc.2, 10.0.13, 9.0.21, 8.0.32), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet microsoft.aspnetcore.components.webassembly.server
- Affected
- >= 10.0.0, <= 10.0.12>= 11.0.0-preview.1, <= 11.0.0-rc.1>= 8.0.0, <= 8.0.31>= 9.0.0, <= 9.0.20
- Fixed in
- 11.0.0-rc.2, 10.0.13, 8.0.32, 9.0.21
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qjpx-jqm5-h2c4 lists affected ranges: NuGet microsoft.aspnetcore.components.webassembly.server >=10.0.0 =11.0.0-preview.1 =8.0.0 =9.0.0 <9.0.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qjpx-jqm5-h2c4 lists affected ranges: NuGet microsoft.aspnetcore.components.webassembly.server >=10.0.0 =11.0.0-preview.1 =8.0.0 =9.0.0 <=9.0.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-96230: 0.95% estimated exploitation activity in the next 30 days; percentile 61.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Executive summary Microsoft is releasing this security advisory to provide information about a vulnerability in Microsoft.AspNetCore.Components.WebAssembly.Server. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. The Blazor WebAssembly development-server debug page can reflect unencoded exception text, allowing cross-origin script injection through the unauthenticated /framework/debug endpoint used by dotnet watch. Announcement Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/478 CVSS Details - Version: 3.1 - Severity: High - Score: 8.8 - Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')) Affected Platforms - Platforms: Windows, Linux, macOS - Architectures: All <a name="affected-packages"</aAffected Packages The vulnerability affects Microsoft .NET projects that…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qjpx-jqm5-h2c4
- Revision 1 · created ·
Published from osv record GHSA-qjpx-jqm5-h2c4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-96230 Advisory: Microsoft Security Advisory CVE-2026-96230 - ASP.NET Core Remote Code Execution Vulnerability IDs: CVE-2026-96230, GHSA-qjpx-jqm5-h2c4 Record: https://patchnext.com/advisories/cve-2026-96230 (revision 2, source checked 26 Oct 2026, 17:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: microsoft.aspnetcore.components.webassembly.server 11.0.0-rc.2, 10.0.13, 9.0.21, 8.0.32. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet microsoft.aspnetcore.components.webassembly.server: affected >= 10.0.0, <= 10.0.12; >= 11.0.0-preview.1, <= 11.0.0-rc.1; >= 8.0.0, <= 8.0.31; >= 9.0.0, <= 9.0.20; fixed in 11.0.0-rc.2, 10.0.13, 8.0.32, 9.0.21 ## Suggested inspection (read-only) - NuGet microsoft.aspnetcore.components.webassembly.server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on microsoft.aspnetcore.components.webassembly.server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qjpx-jqm5-h2c4 (OSV record GHSA-qjpx-jqm5-h2c4 lists affected ranges: NuGet microsoft.aspnetcore.components.webassembly.server >=10.0.0 =11.0.0-preview.1 =8.0.0 =9.0.0 <9.0.21 (fixed)) - Verified: https://github.com/advisories/GHSA-qjpx-jqm5-h2c4 (GitHub-reviewed advisory GHSA-qjpx-jqm5-h2c4 lists affected ranges: NuGet microsoft.aspnetcore.components.webassembly.server >=10.0.0 =11.0.0-preview.1 =8.0.0 =9.0.0 <=9.0.20) Commands are suggestions: review each one before running it.
Loading voting…