Skip to content

← Actionable
High, CVSS 7.8amended

containerd CRI plugin: Checkpoint restore bypasses destination security context

CVE-2026-95837GHSA-p7v4-vr35-mj6f

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/containerd/containerd/v2

    Affected
    >= 2.1.0, < 2.2.7>= 2.3.0, < 2.3.4
    Fixed in
    2.3.4, 2.2.7
  • Go github.com/containerd/containerd

    Affected
    every version
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-95837: 0.11% estimated exploitation activity in the next 30 days; percentile 1.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability in containerd's CRI implementation allows a container restored from an untrusted checkpoint via the CreateContainer API to bypass the destination security context and execute with elevated privileges. When restoring a container from a checkpoint archive or annotated OCI image, CRIU restores process credentials, Linux capabilities, nonewprivs, and seccomp state directly from checkpoint data rather than enforcing the destination CRI ContainerConfig. An attacker who can run a container with a crafted checkpoint image can execute processes as root with full capabilities and no enforced seccomp filters despite restrictive security policies requested by the orchestrator. Additionally, containerd's CRI status reporting reflects the requested configuration rather than the actual restored process state, masking the privilege discrepancy from orchestrators. This issue affects Linux systems running containerd with CRI checkpoint restore enabled; users not utilizing CRI…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p7v4-vr35-mj6f

  2. Revision 2 · amended ·

    Amended from osv record GO-2026-6791

  3. Revision 1 · created ·

    Published from osv record GHSA-p7v4-vr35-mj6f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-95837

Advisory: containerd CRI plugin: Checkpoint restore bypasses destination security context
IDs: CVE-2026-95837, GHSA-p7v4-vr35-mj6f
Record: https://patchnext.com/advisories/cve-2026-95837 (revision 3, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/containerd/containerd/v2 2.3.4, 2.2.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/containerd/containerd/v2: affected >= 2.1.0, < 2.2.7; >= 2.3.0, < 2.3.4; fixed in 2.3.4, 2.2.7
- Go github.com/containerd/containerd: affected every version

## Suggested inspection (read-only)
- Go github.com/containerd/containerd/v2: check the installed version with your package manager.
- Go github.com/containerd/containerd: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/containerd/containerd/v2, github.com/containerd/containerd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6791 (OSV record GO-2026-6791 lists affected ranges: Go github.com/containerd/containerd >=0; Go github.com/containerd/containerd/v2 >=2.1.0 =2.3.0 <2.3.4 (fixed))
- Verified: https://osv.dev/vulnerability/GHSA-p7v4-vr35-mj6f (OSV record GHSA-p7v4-vr35-mj6f lists affected ranges: Go github.com/containerd/containerd/v2 >=2.1.0 =2.3.0 <2.3.4 (fixed))
- Verified: https://github.com/advisories/GHSA-p7v4-vr35-mj6f (GitHub-reviewed advisory GHSA-p7v4-vr35-mj6f lists affected ranges: Go github.com/containerd/containerd/v2 >=2.1.0 =2.3.0 <2.3.4)

Commands are suggestions: review each one before running it.

Loading voting…