Mautic vulnerable to Path Traversal via Campaign Import
CVE-2026-9559GHSA-6r9h-4h75-7q4x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 7.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mautic/core
- Affected
- >= 7.0.0, < 7.1.2
- Fixed in
- 7.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6r9h-4h75-7q4x lists affected ranges: Packagist mautic/core >=7.0.0 <7.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-9559: 0.58% estimated exploitation activity in the next 30 days; percentile 47.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A path traversal vulnerability exists in the campaign import feature of Mautic 7. When extracting uploaded ZIP files during campaign imports, a flaw in the validation logic allows file paths to escape the intended temporary directories. Impact An authenticated user with campaign import privileges (campaign:imports:create) can write arbitrary PHP files to sensitive system directories. An attacker can exploit this to overwrite critical internal configuration or cache components, resulting in Remote Code Execution (RCE) under the context of the web server user. Patched Versions This security issue has been addressed in the following release: 7.1.2 Note: Mautic 6.x, 5.x, and 4.x branches are not affected by this vulnerability. For general security support regarding legacy Mautic 4 releases, please refer to the ELTS page. Workarounds There are no official workarounds. To mitigate this risk without upgrading, revoke campaign import permissions (campaign:imports:create) from…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6r9h-4h75-7q4x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-9559 Advisory: Mautic vulnerable to Path Traversal via Campaign Import IDs: CVE-2026-9559, GHSA-6r9h-4h75-7q4x Record: https://patchnext.com/advisories/cve-2026-9559 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mautic/core 7.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mautic/core: affected >= 7.0.0, < 7.1.2; fixed in 7.1.2 ## Suggested inspection (read-only) - Packagist mautic/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mautic/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6r9h-4h75-7q4x (GitHub-reviewed advisory GHSA-6r9h-4h75-7q4x lists affected ranges: Packagist mautic/core >=7.0.0 <7.1.2) Commands are suggestions: review each one before running it.
Loading voting…