Skip to content

← Actionable
Medium, CVSS 6.4

Mautic Focus component Vulnerable to SSRF

CVE-2026-9557GHSA-jmv8-8j9j-rcpc

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mautic/core

    Affected
    >= 4.0.0, <= 4.4.13>= 5.0.0, < 5.2.11>= 6.0.0, < 6.0.9>= 7.0.0, < 7.1.2
    Fixed in
    5.2.11, 7.1.2, 6.0.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-9557: 0.15% estimated exploitation activity in the next 30 days; percentile 3.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Server-Side Request Forgery (SSRF) vulnerability exists in the Mautic Focus component (MauticFocusBundle). Under certain conditions, insufficiency in validating user-supplied URLs allows authenticated users to trigger outbound HTTP requests from the hosting server. Impact An authenticated user with access to the Mautic panel can exploit this vulnerability to perform internal port probing or force the server to initiate requests to external or arbitrary internal destinations. This can enable internal network reconnaissance or mapping of firewalled infrastructure. Patched Versions This security issue has been fixed in the following releases: 7.1.2 6.0.9 5.2.11 4.4.20 ELTS Mautic strongly recommend upgrading to the latest version corresponding to your release branch. Workarounds There are no official workarounds. To completely mitigate the exposure without upgrading, disabling or limiting external network access from the Mautic web server to internal-only subnets/local hosts…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jmv8-8j9j-rcpc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-9557

Advisory: Mautic Focus component Vulnerable to SSRF
IDs: CVE-2026-9557, GHSA-jmv8-8j9j-rcpc
Record: https://patchnext.com/advisories/cve-2026-9557 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: mautic/core 7.1.2, 6.0.9, 5.2.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mautic/core: affected >= 4.0.0, <= 4.4.13; >= 5.0.0, < 5.2.11; >= 6.0.0, < 6.0.9; >= 7.0.0, < 7.1.2; fixed in 5.2.11, 7.1.2, 6.0.9

## Suggested inspection (read-only)
- Packagist mautic/core: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mautic/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jmv8-8j9j-rcpc (GitHub-reviewed advisory GHSA-jmv8-8j9j-rcpc lists affected ranges: Packagist mautic/core >=4.0.0 =5.0.0 =6.0.0 =7.0.0 <7.1.2)

Commands are suggestions: review each one before running it.

Loading voting…