Skip to content

← Actionable
High, CVSS 8.7amended

vllm p2p never connected zmq_exhaustion

CVE-2026-94624GHSA-frvg-qw88-hww9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.32.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    < 0.32.0
    Fixed in
    0.32.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2026-94624: 0.43% estimated exploitation activity in the next 30 days; percentile 37.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When the `OffloadingConnector` uses `TieringOffloadingSpec` with a P2P secondary tier, an API client can submit many unique non-listening peer addresses through `kv_transfer_params.prefill`. vLLM keeps every never-established P2P session and its ZeroMQ sockets after the request finishes. On vLLM 0.26.0, 340 such peers filled the default ZeroMQ context socket quota; creating the next peer raised an uncaught `ZMQError`, terminated `EngineCore`, and shut down the API server. The path was reproduced with a normal API key and no access to the internal P2P listener.

Details

Root cause In vLLM 0.26.0, `P2PSecondaryTierManager.on_new_request()` reads the following request-controlled fields: ```json { "kv_transfer_params": { "prefill": { "kv_request_id": "id", "remote_host": "127.0.0.1", "remote_port": 49101 } } } ``` `on_new_request()` calls `_get_or_create_session(peer_id)`. This calls `ZmqTransport.connect()`, creates a `P2PSession`, and stores it in `_sessions` before…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record PYSEC-2026-4006

  2. Revision 2 · amended ·

    Amended from osv record GHSA-frvg-qw88-hww9

  3. Revision 1 · created ·

    Published from ghsa record GHSA-frvg-qw88-hww9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-94624

Advisory: vllm p2p never connected zmq_exhaustion
IDs: CVE-2026-94624, GHSA-frvg-qw88-hww9
Record: https://patchnext.com/advisories/cve-2026-94624 (revision 3, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.32.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected < 0.32.0; fixed in 0.32.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-frvg-qw88-hww9 (OSV record GHSA-frvg-qw88-hww9 lists affected ranges: PyPI vllm >=0 <0.32.0 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2026-4006 (OSV record PYSEC-2026-4006 lists affected ranges: PyPI vllm >=0 <0.30.0 (fixed))
- Verified: https://github.com/advisories/GHSA-frvg-qw88-hww9 (GitHub-reviewed advisory GHSA-frvg-qw88-hww9 lists affected ranges: PyPI vllm >=0 <0.32.0)

Commands are suggestions: review each one before running it.

Loading voting…