Skip to content

← Actionable
Critical, CVSS 10.0amended

Podman: The podman run command can be instructed to disable almost all sandboxing by image annotation

CVE-2026-94603GHSA-2cvf-wqm6-wr9g

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/containers/podman/v5

    Affected
    >= 4.4.0, < 5.8.8
    Fixed in
    5.8.8
  • Go github.com/containers/podman/v3

    Affected
    every version
    Fixed in
    no fixed version recorded
  • Go github.com/containers/podman

    Affected
    >= 4.4.0, < 5.8.8
    Fixed in
    5.8.8
  • Go github.com/containers/podman/v2

    Affected
    every version
    Fixed in
    no fixed version recorded
  • Go go.podman.io/podman/v6

    Affected
    >= 6.0.0, < 6.1.3
    Fixed in
    6.1.3
  • Go github.com/containers/podman/v4

    Affected
    >= 4.4.0, < 5.8.8
    Fixed in
    5.8.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-94603: 0.53% estimated exploitation activity in the next 30 days; percentile 45.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Podman v4.4.0 added a feature where container checkpoints (from the `podman container checkpoint` command) could be distributed via OCI registry, and pulled from that registry and run via the `podman run` command. This allowed easy transfer of checkpoints between systems. However, checkpoints allow complete control of how the container is created - including full control of the container sandbox. When `podman run` detects a checkpoint, it will silently ignore all user input regarding how the container should be created - for example, `podman run --cap-drop=ALL` on an image that is determined to be a checkpoint will ignore `--cap-drop=all` and use the set of capabilities specified by the checkpoint image instead, which could include all capabilities. Podman identifies checkpoint images by looking for an annotation, `io.podman.annotations.checkpoint.runtime.name`. If this annotation is set, the image is treated as a checkpoint. Conflating container images and checkpoints in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-2cvf-wqm6-wr9g

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-2cvf-wqm6-wr9g

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-2cvf-wqm6-wr9g

  4. Revision 2 · amended ·

    Amended from osv record GO-2026-6770

  5. Revision 1 · created ·

    Published from osv record GHSA-2cvf-wqm6-wr9g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-94603

Advisory: Podman: The `podman run` command can be instructed to disable almost all sandboxing by image annotation
IDs: CVE-2026-94603, GHSA-2cvf-wqm6-wr9g
Record: https://patchnext.com/advisories/cve-2026-94603 (revision 5, source checked 4 Nov 2026, 06:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: github.com/containers/podman/v5 5.8.8; github.com/containers/podman 5.8.8; go.podman.io/podman/v6 6.1.3; github.com/containers/podman/v4 5.8.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/containers/podman/v5: affected >= 4.4.0, < 5.8.8; fixed in 5.8.8
- Go github.com/containers/podman/v3: affected every version
- Go github.com/containers/podman: affected >= 4.4.0, < 5.8.8; fixed in 5.8.8
- Go github.com/containers/podman/v2: affected every version
- Go go.podman.io/podman/v6: affected >= 6.0.0, < 6.1.3; fixed in 6.1.3
- Go github.com/containers/podman/v4: affected >= 4.4.0, < 5.8.8; fixed in 5.8.8

## Suggested inspection (read-only)
- Go github.com/containers/podman/v5: check the installed version with your package manager.
- Go github.com/containers/podman/v3: check the installed version with your package manager.
- Go github.com/containers/podman: check the installed version with your package manager.
- Go github.com/containers/podman/v2: check the installed version with your package manager.
- Go go.podman.io/podman/v6: check the installed version with your package manager.
- Go github.com/containers/podman/v4: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/containers/podman/v5, github.com/containers/podman/v3, github.com/containers/podman, github.com/containers/podman/v2, go.podman.io/podman/v6, github.com/containers/podman/v4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2cvf-wqm6-wr9g (OSV record GHSA-2cvf-wqm6-wr9g lists affected ranges: Go github.com/containers/podman >=4.4.0 =6.0.0 <6.1.3 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6770 (OSV record GO-2026-6770 lists affected ranges: Go github.com/containers/podman >=0; Go github.com/containers/podman/v2 >=0; Go github.com/containers/podman/v3 >=0; Go github.com/containers/podman/v4 >=4.4.0; Go github.com/containers/podman/v5 >=0 =6.0.0 <6.1.3 (fixed))
- Verified: https://github.com/advisories/GHSA-2cvf-wqm6-wr9g (GitHub-reviewed advisory GHSA-2cvf-wqm6-wr9g lists affected ranges: Go github.com/containers/podman >=4.4.0 =6.0.0 <6.1.3)
- Verified: https://github.com/advisories/GHSA-2cvf-wqm6-wr9g (GitHub-reviewed advisory GHSA-2cvf-wqm6-wr9g lists affected ranges: Go go.podman.io/podman/v6 >=6.0.0 =4.4.0 =4.4.0 <5.8.8)
- Verified: https://osv.dev/vulnerability/GHSA-2cvf-wqm6-wr9g (OSV record GHSA-2cvf-wqm6-wr9g lists affected ranges: Go github.com/containers/podman/v4 >=4.4.0 =6.0.0 =4.4.0 <5.8.8 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…