Skip to content

← Actionable
Medium, CVSS 6.3amended

Next.js: Pending use cache fill can leak Draft Mode content into regular responses and persisted pages

CVE-2026-94544GHSA-3w37-wq28-93x7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 16.3.0, < 16.3.8
    Fixed in
    16.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-94544: 0.18% estimated exploitation activity in the next 30 days; percentile 7.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Pending use cache fills are shared across requests for the same key without distinguishing Draft Mode requests from regular requests. When two such requests overlap, the second request receives the first request's fill: - A regular request that overlaps an editor's Draft Mode request receives unpublished content, without any authentication. - A Draft Mode request that overlaps a regular request receives published content instead of the draft. If the overlapping regular request prerenders a page — for example an on-demand prerender of a route that was not prerendered at build time — the unpublished content can be persisted into the generated page and served to all later visitors of that route until the page is revalidated. Since cached functions can be shared across routes, the poisoned page does not need to be the page the editor is previewing. Sites are affected if they enable Cache Components (or experimental.useCache) and serve Draft Mode previews whose cached functions return…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-3w37-wq28-93x7

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-3w37-wq28-93x7

  4. Revision 1 · created ·

    Published from ghsa record GHSA-3w37-wq28-93x7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-94544

Advisory: Next.js: Pending `use cache` fill can leak Draft Mode content into regular responses and persisted pages
IDs: CVE-2026-94544, GHSA-3w37-wq28-93x7
Record: https://patchnext.com/advisories/cve-2026-94544 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 16.3.0, < 16.3.8; fixed in 16.3.8

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3w37-wq28-93x7 (GitHub-reviewed advisory GHSA-3w37-wq28-93x7 lists affected ranges: npm next >=16.3.0 <16.3.8)
- Verified: https://osv.dev/vulnerability/GHSA-3w37-wq28-93x7 (OSV record GHSA-3w37-wq28-93x7 lists affected ranges: npm next >=16.3.0 <16.3.8 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…