Skip to content

← Actionable
Medium, CVSS 6.3amended

Next.js has cache poisoning of SSG and ISR pages in self-hosted applications

CVE-2026-94543GHSA-4jqv-mc3x-m676

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.3.8, 15.5.27), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 15.0.0, < 15.5.27>= 16.0.0, < 16.3.8
    Fixed in
    15.5.27, 16.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-94543: 0.51% estimated exploitation activity in the next 30 days; percentile 43.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Self-hosted Next.js applications that use the Pages Router with statically generated (SSG) or incrementally regenerated (ISR) pages can have a page's cache entry replaced with content from a different route, causing the affected page to serve wrong content to every visitor until the entry is revalidated. Applications deployed on Vercel are not affected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-4jqv-mc3x-m676

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-4jqv-mc3x-m676

  4. Revision 1 · created ·

    Published from ghsa record GHSA-4jqv-mc3x-m676

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-94543

Advisory: Next.js has cache poisoning of SSG and ISR pages in self-hosted applications
IDs: CVE-2026-94543, GHSA-4jqv-mc3x-m676
Record: https://patchnext.com/advisories/cve-2026-94543 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.3.8, 15.5.27. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 15.0.0, < 15.5.27; >= 16.0.0, < 16.3.8; fixed in 15.5.27, 16.3.8

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4jqv-mc3x-m676 (GitHub-reviewed advisory GHSA-4jqv-mc3x-m676 lists affected ranges: npm next >=15.0.0 =16.0.0 <16.3.8)
- Verified: https://osv.dev/vulnerability/GHSA-4jqv-mc3x-m676 (OSV record GHSA-4jqv-mc3x-m676 lists affected ranges: npm next >=15.0.0 =16.0.0 <16.3.8 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…