Next.js has cache poisoning in SSG/ISR rendering that leads to cross-user content substitution and persistent denial of service
CVE-2026-94484GHSA-mcj8-r9mp-w47p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.3.8, 15.5.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next
- Affected
- >= 16.0.0, < 16.3.8>= 15.0.0, < 15.5.27
- Fixed in
- 15.5.27, 16.3.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mcj8-r9mp-w47p lists affected ranges: npm next >=16.0.0 =15.0.0 <15.5.27
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mcj8-r9mp-w47p lists affected ranges: npm next >=16.0.0 =15.0.0 <15.5.27 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-94484: 0.24% estimated exploitation activity in the next 30 days; percentile 15.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Next.js applications that use a root-level catch-all page together with statically generated or Incremental Static Regeneration routes can have their shared response cache poisoned by a single unauthenticated crafted request.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-mcj8-r9mp-w47p
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-mcj8-r9mp-w47p
- Revision 1 · created ·
Published from ghsa record GHSA-mcj8-r9mp-w47p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-94484 Advisory: Next.js has cache poisoning in SSG/ISR rendering that leads to cross-user content substitution and persistent denial of service IDs: CVE-2026-94484, GHSA-mcj8-r9mp-w47p Record: https://patchnext.com/advisories/cve-2026-94484 (revision 4, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next 16.3.8, 15.5.27. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next: affected >= 16.0.0, < 16.3.8; >= 15.0.0, < 15.5.27; fixed in 15.5.27, 16.3.8 ## Suggested inspection (read-only) - `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mcj8-r9mp-w47p (GitHub-reviewed advisory GHSA-mcj8-r9mp-w47p lists affected ranges: npm next >=16.0.0 =15.0.0 <15.5.27) - Verified: https://osv.dev/vulnerability/GHSA-mcj8-r9mp-w47p (OSV record GHSA-mcj8-r9mp-w47p lists affected ranges: npm next >=16.0.0 =15.0.0 <15.5.27 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…