Skip to content

← Actionable
High, CVSS 8.3amended

Next.js has Server-Side Request Forgery in Image Optimization

CVE-2026-94483GHSA-cjq9-62q9-8jv4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.3.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 16.0.0, < 16.3.8
    Fixed in
    16.3.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-94483: 0.33% estimated exploitation activity in the next 30 days; percentile 26.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker-controlled, allow-listed remote URL can lead to server-side request forgery (e.g. to private IPs) during Image Optimization. Workaround Audit allow-listed remote URLs in images.remotePatterns (see https://nextjs.org/docs/app/getting-started/images#remote-images) for hosts that may not be trusted with their DNS entries. If no images.remotePatterns are configured, your app is not affected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-cjq9-62q9-8jv4

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-cjq9-62q9-8jv4

  4. Revision 1 · created ·

    Published from ghsa record GHSA-cjq9-62q9-8jv4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-94483

Advisory: Next.js has Server-Side Request Forgery in Image Optimization
IDs: CVE-2026-94483, GHSA-cjq9-62q9-8jv4
Record: https://patchnext.com/advisories/cve-2026-94483 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.3.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 16.0.0, < 16.3.8; fixed in 16.3.8

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cjq9-62q9-8jv4 (GitHub-reviewed advisory GHSA-cjq9-62q9-8jv4 lists affected ranges: npm next >=16.0.0 <16.3.8)
- Verified: https://osv.dev/vulnerability/GHSA-cjq9-62q9-8jv4 (OSV record GHSA-cjq9-62q9-8jv4 lists affected ranges: npm next >=16.0.0 <16.3.8 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…