Spree: Broken Access Control in PATCH /api/v3/store/carts/:id/associate (IDOR)
CVE-2026-94462GHSA-4825-p4xm-pcf2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (spree_api 5.5.4, 5.4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems spree_api
- Affected
- >= 5.4.0, < 5.4.4>= 5.5.0, < 5.5.4
- Fixed in
- 5.5.4, 5.4.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4825-p4xm-pcf2 lists affected ranges: RubyGems spree_api >=5.4.0 =5.5.0 <5.5.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4825-p4xm-pcf2 lists affected ranges: RubyGems spree_api >=5.4.0 =5.5.0 <5.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-94462: 0.38% estimated exploitation activity in the next 30 days; percentile 32.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Store API v3 endpoint PATCH /api/v3/store/carts/:id/associate binds a guest cart to the authenticated caller without verifying possession of that cart. It locates the cart by prefixed ID only — currentstore.carts.where(user: [nil, currentuser]).findbyprefixid!(params[:id]) — and omits the authorize!(:update, @cart, carttoken) check that every other action in the controller performs via CartResolvable. Because prefixed IDs are a reversible Sqids encoding of the auto-increment primary key (obfuscation, not a token), an authenticated customer can name arbitrary guest cart IDs, take them over, and read the checkout addresses stored on them. This is broken access control / IDOR, reachable by any low-privilege registered user. Severity Requires an authenticated store account and depends on target guest carts already carrying an address and not yet being associated, on a store not running in loginrequired mode. Confidentiality impact is the driver (guest checkout PII); integrity…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4825-p4xm-pcf2
- Revision 1 · created ·
Published from osv record GHSA-4825-p4xm-pcf2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-94462 Advisory: Spree: Broken Access Control in `PATCH /api/v3/store/carts/:id/associate` (IDOR) IDs: CVE-2026-94462, GHSA-4825-p4xm-pcf2 Record: https://patchnext.com/advisories/cve-2026-94462 (revision 2, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: spree_api 5.5.4, 5.4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems spree_api: affected >= 5.4.0, < 5.4.4; >= 5.5.0, < 5.5.4; fixed in 5.5.4, 5.4.4 ## Suggested inspection (read-only) - RubyGems spree_api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on spree_api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4825-p4xm-pcf2 (OSV record GHSA-4825-p4xm-pcf2 lists affected ranges: RubyGems spree_api >=5.4.0 =5.5.0 <5.5.4 (fixed)) - Verified: https://github.com/advisories/GHSA-4825-p4xm-pcf2 (GitHub-reviewed advisory GHSA-4825-p4xm-pcf2 lists affected ranges: RubyGems spree_api >=5.4.0 =5.5.0 <5.5.4) Commands are suggestions: review each one before running it.
Loading voting…