vm2 contains a sandbox escape vulnerability
CVE-2026-93605GHSA-pq68-rvw4-xp4r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.12.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- <= 3.12.0
- Fixed in
- 3.12.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pq68-rvw4-xp4r lists affected ranges: npm vm2 >=0 <=3.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pq68-rvw4-xp4r lists affected ranges: npm vm2 >=0 <3.12.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-93605: 0.48% estimated exploitation activity in the next 30 days; percentile 41.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
vm2 NodeVM versions before 3.12.1 contain a sandbox escape vulnerability where the DANGEROUSBUILTINS denylist omits childprocess despite blocking other host-spawning modules. Attackers can require childprocess and execute arbitrary commands on the host system when NodeVM is configured with builtin:[''] or explicit childprocess allowance. This fork hardens NodeVM with a DANGEROUSBUILTINS denylist that blocks host‑code‑reaching core modules even when the sandbox requests builtin:[''] or names them explicitly — the list contains module, workerthreads, cluster, vm, repl, inspector, process, traceevents, wasi, diagnosticschannel, asynchooks, perfhooks, v8, os, dns, and test. It omits childprocess — the single most direct command‑execution primitive. As a result, a sandbox running under require:{builtin:['']} (or the fork's own documented ['','-http','-net',…] subtract pattern) can require('childprocess').execSync(...) and execute arbitrary commands on the host. The omission is internally…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-pq68-rvw4-xp4r
- Revision 2 · amended ·
Amended from osv record GHSA-pq68-rvw4-xp4r
- Revision 1 · created ·
Published from ghsa record GHSA-pq68-rvw4-xp4r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-93605 Advisory: vm2 contains a sandbox escape vulnerability IDs: CVE-2026-93605, GHSA-pq68-rvw4-xp4r Record: https://patchnext.com/advisories/cve-2026-93605 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.12.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected <= 3.12.0; fixed in 3.12.1 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pq68-rvw4-xp4r (GitHub-reviewed advisory GHSA-pq68-rvw4-xp4r lists affected ranges: npm vm2 >=0 <=3.12.0) - Verified: https://osv.dev/vulnerability/GHSA-pq68-rvw4-xp4r (OSV record GHSA-pq68-rvw4-xp4r lists affected ranges: npm vm2 >=0 <3.12.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…