postcss-selector-parser allows denial of service through uncontrolled AST recursion
CVE-2026-9358GHSA-w9m9-85wc-3x92
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (postcss-selector-parser 7.1.3, 6.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 6.1.0, < 6.1.3>= 7.1.0, < 7.1.3
- Fixed in
- 6.1.3, 7.1.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w9m9-85wc-3x92 lists affected ranges: npm postcss-selector-parser >=6.1.0 =7.1.0 <7.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w9m9-85wc-3x92 lists affected ranges: npm postcss-selector-parser >=6.1.0 =7.1.0 <7.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-9358: 0.33% estimated exploitation activity in the next 30 days; percentile 25.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was determined in postcss-selector-parser before 6.1.3 and 7.1.1. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled recursion. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. The vendor explains, that according to his definition "DoS on server-side on user-generated CSS is low risk for us (since most users compile own CSS with PostCSS)."
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-w9m9-85wc-3x92
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-w9m9-85wc-3x92
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-9358 Advisory: postcss-selector-parser allows denial of service through uncontrolled AST recursion IDs: CVE-2026-9358, GHSA-w9m9-85wc-3x92 Record: https://patchnext.com/advisories/cve-2026-9358 (revision 3, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: postcss-selector-parser 7.1.3, 6.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm postcss-selector-parser: affected >= 6.1.0, < 6.1.3; >= 7.1.0, < 7.1.3; fixed in 6.1.3, 7.1.3 ## Suggested inspection (read-only) - `npm ls postcss-selector-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on postcss-selector-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w9m9-85wc-3x92 (OSV record GHSA-w9m9-85wc-3x92 lists affected ranges: npm postcss-selector-parser >=6.1.0 =7.1.0 <7.1.3 (fixed)) - Verified: https://github.com/advisories/GHSA-w9m9-85wc-3x92 (GitHub-reviewed advisory GHSA-w9m9-85wc-3x92 lists affected ranges: npm postcss-selector-parser >=6.1.0 =7.1.0 <7.1.3) Commands are suggestions: review each one before running it.
Loading voting…