Skip to content

← Actionable
Unratedamended

Apache Tomcat: Possible TLS 1.3 connection failures

CVE-2026-93446

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tomcat 11.0.27, 10.1.61, 9.0.123), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Bitnami tomcat

    Affected
    >= 9.0.90, < 9.0.123>= 10.1.25, < 10.1.61>= 11.0.0, < 11.0.27
    Fixed in
    10.1.61, 9.0.123, 11.0.27

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-93446: 0.59% estimated exploitation activity in the next 30 days; percentile 48.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Incomplete cleanup vulnerability in Apache Tomcat could cause TLS 1.3 connections to fail intermittently. This issue affects Apache Tomcat: from 11.0.0 through 11.0.26, from 10.1.25 through 10.1.60, from 9.0.90 through 9.0.122. Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record BIT-tomcat-2026-93446

  2. Revision 1 · created ·

    Published from osv record BIT-tomcat-2026-93446

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-93446

Advisory: Apache Tomcat: Possible TLS 1.3 connection failures
IDs: CVE-2026-93446
Record: https://patchnext.com/advisories/cve-2026-93446 (revision 2, source checked 31 Oct 2026, 07:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tomcat 11.0.27, 10.1.61, 9.0.123. A vendor fix does not mean a deployment is fixed.

## Affected components
- Bitnami tomcat: affected >= 9.0.90, < 9.0.123; >= 10.1.25, < 10.1.61; >= 11.0.0, < 11.0.27; fixed in 10.1.61, 9.0.123, 11.0.27

## Suggested inspection (read-only)
- Bitnami tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/BIT-tomcat-2026-93446 (OSV record BIT-tomcat-2026-93446 lists affected ranges: Bitnami tomcat >=9.0.90 =10.1.25 =11.0.0 <11.0.27 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…