Skip to content

← Actionable
Medium, CVSS 5.3amended

Mesop: Unauthenticated ANSI Escape Sequence Injection in CSP Reporting Endpoint

CVE-2026-93421GHSA-g7f6-rxc4-qhph

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mesop 1.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mesop

    Affected
    <= 1.3.3
    Fixed in
    1.3.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N · score source
EPSS
  • CVE-2026-93421: 0.53% estimated exploitation activity in the next 30 days; percentile 44.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The /csp endpoint accepts unauthenticated JSON reports and logs user-controlled values directly to stdout using print() without escaping control characters. A remote attacker can include ANSI/VT100 escape sequences in fields such as blocked-uri or document-uri. When the logs are viewed in an ANSI-capable terminal, these sequences can manipulate the displayed output (e.g., clear the screen, hide text, or inject misleading messages), affecting the integrity of operator-facing logs. Details The CSP reporting endpoint accepts arbitrary JSON and prints several request fields directly: mesop/server/staticfileserving.py Since these values are written to stdout without sanitization, ANSI escape sequences supplied by a remote client are preserved and interpreted by ANSI-compatible terminals. PoC Send the following request: The request is accepted (HTTP 204), and the injected escape sequences are written to stdout unchanged. When the captured output is rendered in a VT100-compatible…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-g7f6-rxc4-qhph

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-g7f6-rxc4-qhph

  4. Revision 1 · created ·

    Published from ghsa record GHSA-g7f6-rxc4-qhph

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-93421

Advisory: Mesop: Unauthenticated ANSI Escape Sequence Injection in CSP Reporting Endpoint
IDs: CVE-2026-93421, GHSA-g7f6-rxc4-qhph
Record: https://patchnext.com/advisories/cve-2026-93421 (revision 4, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mesop 1.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mesop: affected <= 1.3.3; fixed in 1.3.4

## Suggested inspection (read-only)
- `python -m pip show mesop`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mesop.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g7f6-rxc4-qhph (GitHub-reviewed advisory GHSA-g7f6-rxc4-qhph lists affected ranges: PyPI mesop >=0 <=1.3.3)
- Verified: https://osv.dev/vulnerability/GHSA-g7f6-rxc4-qhph (OSV record GHSA-g7f6-rxc4-qhph lists affected ranges: PyPI mesop >=0 <1.3.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…