Skip to content

← Actionable
Medium, CVSS 5.3amended

vm2 has access to VM2_INTERNAL_STATE_DO_NOT_USE_OR_PROGRAM_WILL_FAIL

CVE-2026-92963GHSA-2cm2-m3w5-gp2f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    < 3.11.2
    Fixed in
    3.11.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-92963: 0.34% estimated exploitation activity in the next 30 days; percentile 27.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary https://github.com/patriksimek/vm2/security/advisories/GHSA-wp5r-2gw5-m7q7 is not fully patched. Details It is still possible to get access to VM2INTERNALSTATEDONOTUSEORPROGRAMWILLFAIL. PoC

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2cm2-m3w5-gp2f

  2. Revision 1 · created ·

    Published from osv record GHSA-2cm2-m3w5-gp2f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-92963

Advisory: vm2 has access to `VM2_INTERNAL_STATE_DO_NOT_USE_OR_PROGRAM_WILL_FAIL`
IDs: CVE-2026-92963, GHSA-2cm2-m3w5-gp2f
Record: https://patchnext.com/advisories/cve-2026-92963 (revision 2, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected < 3.11.2; fixed in 3.11.2

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2cm2-m3w5-gp2f (OSV record GHSA-2cm2-m3w5-gp2f lists affected ranges: npm vm2 >=0 <3.11.2 (fixed))
- Verified: https://github.com/advisories/GHSA-2cm2-m3w5-gp2f (GitHub-reviewed advisory GHSA-2cm2-m3w5-gp2f lists affected ranges: npm vm2 >=0 <3.11.2)

Commands are suggestions: review each one before running it.

Loading voting…