vm2 setup-sandbox.js violates Defense Invariant #11 in stack-trace formatter
CVE-2026-92962GHSA-q3fm-4wcw-g57x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- <= 3.11.3
- Fixed in
- 3.11.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q3fm-4wcw-g57x lists affected ranges: npm vm2 >=0 <3.11.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q3fm-4wcw-g57x lists affected ranges: npm vm2 >=0 <=3.11.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N · score source
- EPSS
- CVE-2026-92962: 0.15% estimated exploitation activity in the next 30 days; percentile 4.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary defaultSandboxPrepareStackTrace in lib/setup-sandbox.js (lines 605, 607) appends to a fresh sandbox-realm lines = [] via lines[lines.length] = value. This is the exact invariant-violating pattern that GHSA-9qj6-qjgg-37qq (commit ca195f0, 2026-05-01) just patched in neutralizeArraySpeciesBatch and codified as Defense Invariant #11 ("Bridge-internal containers must not invoke sandbox code"). A sandbox-installed Array.prototype[N] setter fires during the bridge's safe-default stack-trace formatting and observes / intercepts each appended line. Details The post-9qj6 audit note in docs/ATTACKS.md (line 2111) states: Equivalent pattern elsewhere in the bridge: audited; thisFromOtherArguments, otherFromThisArguments, and every other index-write site already use thisReflectDefineProperty or otherReflectDefineProperty. neutralizeArraySpeciesBatch was the lone outlier. The audit is scoped to lib/bridge.js. lib/setup-sandbox.js was not covered. defaultSandboxPrepareStackTrace (added…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-q3fm-4wcw-g57x
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-q3fm-4wcw-g57x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-92962 Advisory: vm2 setup-sandbox.js violates Defense Invariant #11 in stack-trace formatter IDs: CVE-2026-92962, GHSA-q3fm-4wcw-g57x Record: https://patchnext.com/advisories/cve-2026-92962 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected <= 3.11.3; fixed in 3.11.4 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q3fm-4wcw-g57x (OSV record GHSA-q3fm-4wcw-g57x lists affected ranges: npm vm2 >=0 <3.11.4 (fixed)) - Verified: https://github.com/advisories/GHSA-q3fm-4wcw-g57x (GitHub-reviewed advisory GHSA-q3fm-4wcw-g57x lists affected ranges: npm vm2 >=0 <=3.11.3) Commands are suggestions: review each one before running it.
Loading voting…