Skip to content

← Actionable
High, CVSS 7.1amended

vm2: allowAsync: false can be bypassed through Promise thenable assimilation in VM and NodeVM

CVE-2026-92959GHSA-f8gf-w286-fmq2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    <= 3.11.7
    Fixed in
    3.11.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-92959: 0.45% estimated exploitation activity in the next 30 days; percentile 39.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When allowAsync is set to false, vm2 is expected to reject attempts to run asynchronous code. Direct use of Promise.prototype.then is blocked, but Promise static methods still assimilate attacker-controlled thenables. Promise.resolve(thenable), Promise.all([thenable]), Promise.race([thenable]), Promise.any([thenable]), and Promise.allSettled([thenable]) can invoke the thenable's then method in a microtask after VM.run() or NodeVM.run() has already returned. This bypasses the documented async-execution restriction and runs outside the configured timeout, allowing sandboxed code to continue executing after the host believes execution is complete. Details The documented VM option says allowAsync: false should cause attempts to run async code to throw a VMError; README.md:139-145 also recommends using it with timeout. The implementation enforces part of this policy by replacing localPromise.prototype.then with an AsyncErrorHandler when async is disabled: -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-f8gf-w286-fmq2

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-f8gf-w286-fmq2

  4. Revision 1 · created ·

    Published from ghsa record GHSA-f8gf-w286-fmq2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-92959

Advisory: vm2: `allowAsync: false` can be bypassed through Promise thenable assimilation in VM and NodeVM
IDs: CVE-2026-92959, GHSA-f8gf-w286-fmq2
Record: https://patchnext.com/advisories/cve-2026-92959 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected <= 3.11.7; fixed in 3.11.8

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f8gf-w286-fmq2 (GitHub-reviewed advisory GHSA-f8gf-w286-fmq2 lists affected ranges: npm vm2 >=0 <=3.11.7)
- Verified: https://osv.dev/vulnerability/GHSA-f8gf-w286-fmq2 (OSV record GHSA-f8gf-w286-fmq2 lists affected ranges: npm vm2 >=0 <3.11.8 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…