Skip to content

← Actionable
Critical, CVSS 9.9amended

vm2: NodeVM node:-prefixed negative builtin deny bypass exposes child_process

CVE-2026-92957GHSA-8686-vhfx-7r3j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    <= 3.11.6
    Fixed in
    3.11.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-92957: 0.54% estimated exploitation activity in the next 30 days; percentile 45.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary NodeVM normalizes node:-prefixed builtin specifiers during require() resolution, but it does not normalize user-provided negative builtin entries in wildcard policy. As a result, this configuration: does not deny the canonical childprocess builtin. Sandboxed code can require both childprocess and node:childprocess, and receives the host module with process-spawning APIs such as execSync and spawn. The safe proof below only checks module and function reachability. It does not execute any OS command. Affected Mode NodeVM. Affected Configuration This affects users who deny builtins using their node:-prefixed spelling, expecting -node:childprocess to deny require('node:childprocess') and require('childprocess'). Affected Files / Functions - lib/builtin.js - makeBuiltinsFromLegacyOptions - wildcard builtin expansion - exact negative entry check: builtins.indexOf(\-${name}\) - addDefaultBuiltin - lib/resolver.js - Resolver.resolve - lib/setup-node-sandbox.js - requireImpl - node:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8686-vhfx-7r3j

  2. Revision 2 · amended ·

    Amended from osv record GHSA-8686-vhfx-7r3j

  3. Revision 1 · created ·

    Published from ghsa record GHSA-8686-vhfx-7r3j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-92957

Advisory: vm2: NodeVM node:-prefixed negative builtin deny bypass exposes child_process
IDs: CVE-2026-92957, GHSA-8686-vhfx-7r3j
Record: https://patchnext.com/advisories/cve-2026-92957 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected <= 3.11.6; fixed in 3.11.7

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8686-vhfx-7r3j (GitHub-reviewed advisory GHSA-8686-vhfx-7r3j lists affected ranges: npm vm2 >=0 <=3.11.6)
- Verified: https://osv.dev/vulnerability/GHSA-8686-vhfx-7r3j (OSV record GHSA-8686-vhfx-7r3j lists affected ranges: npm vm2 >=0 <3.11.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…