Skip to content

← Actionable
Critical, CVSS 9.9amended

vm2 Custom Module Resolver Can Bypass the External Package Allowlist by Loading a Colliding Host Package

CVE-2026-92951GHSA-c48m-32m9-vx93

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    <= 3.11.6
    Fixed in
    3.11.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-92951: 0.47% estimated exploitation activity in the next 30 days; percentile 40.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary vm2 is a sandbox library for isolating and executing untrusted JavaScript code inside a Node.js process. It can restrict access to built-in modules and external packages. When NodeVM enables an external allowlist together with a custom resolve callback, vm2 checks the requested package name with a non-exact match. For example, if the allowlist only permits left-pad, an attacker can still bypass the check with a colliding package name such as evil-left-pad, because it contains the allowlisted name. If the colliding package already exists in a host path resolvable by the custom resolver, or if the target application's custom resolver / dependency-management workflow downloads the package and places it in a resolvable path, vm2 loads and executes that package in the host context. This lets sandboxed code bypass the module allowlist and may further lead to host code execution. Details NodeVM supports require.external to configure which external npm packages sandboxed code may…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c48m-32m9-vx93

  2. Revision 2 · amended ·

    Amended from osv record GHSA-c48m-32m9-vx93

  3. Revision 1 · created ·

    Published from ghsa record GHSA-c48m-32m9-vx93

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-92951

Advisory: vm2 Custom Module Resolver Can Bypass the External Package Allowlist by Loading a Colliding Host Package
IDs: CVE-2026-92951, GHSA-c48m-32m9-vx93
Record: https://patchnext.com/advisories/cve-2026-92951 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected <= 3.11.6; fixed in 3.11.7

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c48m-32m9-vx93 (GitHub-reviewed advisory GHSA-c48m-32m9-vx93 lists affected ranges: npm vm2 >=0 <=3.11.6)
- Verified: https://osv.dev/vulnerability/GHSA-c48m-32m9-vx93 (OSV record GHSA-c48m-32m9-vx93 lists affected ranges: npm vm2 >=0 <3.11.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…