vm2 CLI provides no sandbox isolation - host-realm require() is reachable from sandboxed scripts
CVE-2026-92950GHSA-jxxv-8r27-vm4p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- <= 3.11.6
- Fixed in
- 3.11.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jxxv-8r27-vm4p lists affected ranges: npm vm2 >=0 <=3.11.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jxxv-8r27-vm4p lists affected ranges: npm vm2 >=0 <3.11.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-92950: 0.20% estimated exploitation activity in the next 30 days; percentile 9.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The vm2 command-line tool installed by npm install -g vm2 and documented in the README's "CLI" section runs the supplied script under NodeVM with require:{external:true} and no root / context / builtin configured. With these defaults the resolver loads every relative or absolute require() target through the host require() function, executing the attacker's module body in the host Node.js process before the result is ever proxied back into the sandbox. A single attacker-controlled file passed to vm2 ./script.js can call require(filename) to re-execute itself in host realm and reach fs, childprocess, etc. The documented sandbox runner is therefore equivalent to node ./script.js. No additional files, flags, or user interaction are required. Details The vulnerability lets a malicious sandboxed script - the file argument to the documented vm2 <file CLI - execute arbitrary code in the host Node.js process, crossing the sandbox → host boundary that vm2 is meant to enforce.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jxxv-8r27-vm4p
- Revision 2 · amended ·
Amended from osv record GHSA-jxxv-8r27-vm4p
- Revision 1 · created ·
Published from ghsa record GHSA-jxxv-8r27-vm4p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-92950 Advisory: vm2 CLI provides no sandbox isolation - host-realm require() is reachable from sandboxed scripts IDs: CVE-2026-92950, GHSA-jxxv-8r27-vm4p Record: https://patchnext.com/advisories/cve-2026-92950 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected <= 3.11.6; fixed in 3.11.7 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jxxv-8r27-vm4p (GitHub-reviewed advisory GHSA-jxxv-8r27-vm4p lists affected ranges: npm vm2 >=0 <=3.11.6) - Verified: https://osv.dev/vulnerability/GHSA-jxxv-8r27-vm4p (OSV record GHSA-jxxv-8r27-vm4p lists affected ranges: npm vm2 >=0 <3.11.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…