Skip to content

← Actionable
Medium, CVSS 4.0amended

vm2: vm.freeze()/vm.readonly() bypass via accessor descriptor

CVE-2026-92949GHSA-633r-hq9m-c4ff

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    >= 3.9.6, <= 3.11.6
    Fixed in
    3.11.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:N
EPSS
  • CVE-2026-92949: 0.32% estimated exploitation activity in the next 30 days; percentile 24.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Untrusted JavaScript running inside new VM().run() / new NodeVM().run() can bypass vm.freeze() / vm.readonly() and mutate a host object the embedder explicitly marked read-only - the documented contract is "prevent sandboxed scripts from adding, changing, or deleting properties". If the frozen host object has an accessor (get/set) own-property, the sandbox can read the host setter back out via Object.getOwnPropertyDescriptor() and call it directly; the call lands in BaseHandler.apply which unwraps the readonly proxy to the raw host object and runs the host setter against it. No non-default VM/NodeVM options are required; the only precondition is that the embedder froze an object whose shape includes an accessor property. A second route to the same sink exists via lookupSetter. PoC Observed output: The first line shows ReadOnlyHandler's documented traps work; the next two show the sandbox mutated the host-side level despite vm.freeze(). Impact A sandboxed script can mutate any…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-633r-hq9m-c4ff

  2. Revision 2 · amended ·

    Amended from osv record GHSA-633r-hq9m-c4ff

  3. Revision 1 · created ·

    Published from ghsa record GHSA-633r-hq9m-c4ff

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-92949

Advisory: vm2: vm.freeze()/vm.readonly() bypass via accessor descriptor
IDs: CVE-2026-92949, GHSA-633r-hq9m-c4ff
Record: https://patchnext.com/advisories/cve-2026-92949 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected >= 3.9.6, <= 3.11.6; fixed in 3.11.7

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-633r-hq9m-c4ff (GitHub-reviewed advisory GHSA-633r-hq9m-c4ff lists affected ranges: npm vm2 >=3.9.6 <=3.11.6)
- Verified: https://osv.dev/vulnerability/GHSA-633r-hq9m-c4ff (OSV record GHSA-633r-hq9m-c4ff lists affected ranges: npm vm2 >=3.9.6 <3.11.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…