Skip to content

← Actionable
Critical, CVSS 9.9amended

vm2: NodeVM builtin allowlist bypass via node:test.run() execArgv allows sandbox escape

CVE-2026-92948GHSA-qhwx-74w5-xhxq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    >= 3.9.6, <= 3.11.6
    Fixed in
    3.11.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-92948: 0.65% estimated exploitation activity in the next 30 days; percentile 51.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary On Node.js 24 and newer, vm2 can expose the host node:test module to sandboxed NodeVM code when the embedder explicitly allows the node:test builtin. Sandbox code can reach that module through require('node:node:test') and call run() with attacker-controlled execArgv. node:test.run() starts a separate Node process for process-isolated test execution and forwards the supplied execArgv values to that process. Supplying --eval=<JavaScript therefore executes arbitrary JavaScript in an unrestricted host Node process, outside the NodeVM sandbox. The PoC confirms that direct sandbox imports of fs, childprocess, module, and process remain denied before the spawned process imports host fs and writes a harmless marker. Affected versions and environment - Package: vm2 - Affected versions: =3.9.6, <=3.11.5 - Latest reproduced version: 3.11.5 - Reproduced runtime: Node.js v24.18.0 - Exact path is not present on Node.js 22 because module.builtinModules does not expose the scheme-only…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qhwx-74w5-xhxq

  2. Revision 2 · amended ·

    Amended from osv record GHSA-qhwx-74w5-xhxq

  3. Revision 1 · created ·

    Published from ghsa record GHSA-qhwx-74w5-xhxq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-92948

Advisory: vm2: NodeVM builtin allowlist bypass via node:test.run() execArgv allows sandbox escape
IDs: CVE-2026-92948, GHSA-qhwx-74w5-xhxq
Record: https://patchnext.com/advisories/cve-2026-92948 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected >= 3.9.6, <= 3.11.6; fixed in 3.11.7

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qhwx-74w5-xhxq (GitHub-reviewed advisory GHSA-qhwx-74w5-xhxq lists affected ranges: npm vm2 >=3.9.6 <=3.11.6)
- Verified: https://osv.dev/vulnerability/GHSA-qhwx-74w5-xhxq (OSV record GHSA-qhwx-74w5-xhxq lists affected ranges: npm vm2 >=3.9.6 <3.11.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…