vm2: Sandboxed code can read and write host-realm memory via Node's shared Buffer pool
CVE-2026-92947GHSA-fcqc-726x-5wfc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- <= 3.11.6
- Fixed in
- 3.11.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fcqc-726x-5wfc lists affected ranges: npm vm2 >=0 <=3.11.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fcqc-726x-5wfc lists affected ranges: npm vm2 >=0 <3.11.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
- EPSS
- CVE-2026-92947: 0.48% estimated exploitation activity in the next 30 days; percentile 41.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Sandboxed code is able to disclose host memory used by small allocations by Buffer.from, Buffer.concat. Details vm2 exposes Buffer object to sandboxed code by default. Small Buffer allocations (for example, Buffer.allocUnsafe(), Buffer.from(array), Buffer.from(string), and Buffer.concat()) use the same Buffer pool, which is shared with the sandbox. This allows sandboxed code to disclose host memory used by the functions listed above. PoC Tested against vm2@3.11.5 in the node REPL. <img width="1044" height="104" alt="Screenshot 2026-07-23 at 17 54 15" src="https://github.com/user-attachments/assets/987b860c-6702-4818-bfaa-c77919c777e5" / Impact Since sandbox acquires an ArrayBuffer that is used by the host, it can disclose sensitive data going through functions mentioned above and even write to these buffers, which can lead to sensitive data exposure and potentially denial-of-service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fcqc-726x-5wfc
- Revision 2 · amended ·
Amended from osv record GHSA-fcqc-726x-5wfc
- Revision 1 · created ·
Published from ghsa record GHSA-fcqc-726x-5wfc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-92947 Advisory: vm2: Sandboxed code can read and write host-realm memory via Node's shared Buffer pool IDs: CVE-2026-92947, GHSA-fcqc-726x-5wfc Record: https://patchnext.com/advisories/cve-2026-92947 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected <= 3.11.6; fixed in 3.11.7 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fcqc-726x-5wfc (GitHub-reviewed advisory GHSA-fcqc-726x-5wfc lists affected ranges: npm vm2 >=0 <=3.11.6) - Verified: https://osv.dev/vulnerability/GHSA-fcqc-726x-5wfc (OSV record GHSA-fcqc-726x-5wfc lists affected ranges: npm vm2 >=0 <3.11.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…