vm2: NodeVM require.external without an explicit require.root grants unrestricted host filesystem access and full RCE
CVE-2026-92946GHSA-j3hm-6rg5-mchv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- <= 3.11.6
- Fixed in
- 3.11.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3hm-6rg5-mchv lists affected ranges: npm vm2 >=0 <=3.11.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j3hm-6rg5-mchv lists affected ranges: npm vm2 >=0 <3.11.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-92946: 0.78% estimated exploitation activity in the next 30 days; percentile 55.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary NodeVM's require.external option lets sandboxed code require() local files and npm packages. When require.external is enabled and require.root is not explicitly set to a path that excludes nodemodules, two defaults combine to fully defeat the sandbox: - require.root defaults to unrestricted — "if omitted every path is allowed." - require.context defaults to "host" — files loaded this way run through the real Node.js require(), not inside any vm2 sandbox. Sandboxed code can therefore require() a relative or absolute path to vm2's own installed package (nodemodules/vm2), obtain the real, unwrapped NodeVM/VM classes, construct a brand-new unrestricted nested NodeVM instance, and execute arbitrary host OS commands via childprocess. This is exploitable using vm2's own documented "Quick Examples" configuration in README.md: root: './' reads as a safety restriction but, in any ordinary npm project layout, ./nodemodules/vm2 sits inside that same directory tree — so the restriction…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-j3hm-6rg5-mchv
- Revision 2 · amended ·
Amended from osv record GHSA-j3hm-6rg5-mchv
- Revision 1 · created ·
Published from ghsa record GHSA-j3hm-6rg5-mchv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-92946 Advisory: vm2: NodeVM `require.external` without an explicit `require.root` grants unrestricted host filesystem access and full RCE IDs: CVE-2026-92946, GHSA-j3hm-6rg5-mchv Record: https://patchnext.com/advisories/cve-2026-92946 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected <= 3.11.6; fixed in 3.11.7 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j3hm-6rg5-mchv (GitHub-reviewed advisory GHSA-j3hm-6rg5-mchv lists affected ranges: npm vm2 >=0 <=3.11.6) - Verified: https://osv.dev/vulnerability/GHSA-j3hm-6rg5-mchv (OSV record GHSA-j3hm-6rg5-mchv lists affected ranges: npm vm2 >=0 <3.11.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…