Skip to content

← Actionable
Critical, CVSS 9.8amended

vm2 sandbox escape on Node.js 26 through a stale PromiseThenLookupChain protector

CVE-2026-92944GHSA-27g9-p43v-cw3v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    >= 3.10.2, <= 3.11.6
    Fixed in
    3.11.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-92944: 0.84% estimated exploitation activity in the next 30 days; percentile 57.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Reporter - Name or handle: [YMsora] - Report date: 2026-08-14 Summary The latest published vm2 release, 3.11.5, and the current main branch are vulnerable to a sandbox escape when used on Node.js 26. An ordinary fulfilled Promise created by an async function can retain an attacker-controlled constructor[Symbol.species] across Promise.prototype.finally(). vm2 installs wrappers on the intrinsic Promise.prototype.then and catch methods. On Node.js 26 / V8 14.6, V8's SetPrototypeProperties path updates these existing data properties without invalidating the PromiseThenLookupChain protector. Promise.prototype.finally() subsequently trusts the stale protector and uses an internal InvokeThen fast path that calls the original native then, bypassing vm2's wrapper and its resetPromiseSpecies(this) hardening. The attacker-controlled species constructor therefore supplies the resolve and reject functions used by a native Promise reaction. A calibrated stack overflow at that native reaction…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-27g9-p43v-cw3v

  2. Revision 2 · amended ·

    Amended from osv record GHSA-27g9-p43v-cw3v

  3. Revision 1 · created ·

    Published from ghsa record GHSA-27g9-p43v-cw3v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-92944

Advisory: vm2 sandbox escape on Node.js 26 through a stale PromiseThenLookupChain protector
IDs: CVE-2026-92944, GHSA-27g9-p43v-cw3v
Record: https://patchnext.com/advisories/cve-2026-92944 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected >= 3.10.2, <= 3.11.6; fixed in 3.11.7

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-27g9-p43v-cw3v (GitHub-reviewed advisory GHSA-27g9-p43v-cw3v lists affected ranges: npm vm2 >=3.10.2 <=3.11.6)
- Verified: https://osv.dev/vulnerability/GHSA-27g9-p43v-cw3v (OSV record GHSA-27g9-p43v-cw3v lists affected ranges: npm vm2 >=3.10.2 <3.11.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…