vm2 NodeVM can replace the host process TLS trust store
CVE-2026-92941GHSA-98xx-8mx4-x7cm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vm2
- Affected
- >= 3.11.3, <= 3.11.6
- Fixed in
- 3.11.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-98xx-8mx4-x7cm lists affected ranges: npm vm2 >=3.11.3 <=3.11.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-98xx-8mx4-x7cm lists affected ranges: npm vm2 >=3.11.3 <3.11.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L
- EPSS
- CVE-2026-92941: 0.29% estimated exploitation activity in the next 30 days; percentile 21.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary vm2 3.11.6 exposes the host tls module to a NodeVM when that builtin is explicitly allowed. Although the module object is wrapped as read-only, its functions still execute against process-wide host state. On Node.js versions that provide tls.setDefaultCACertificates(), sandbox code can replace the certificate authorities trusted by subsequent host-realm TLS clients. The exploit needs only the narrowly allowed tls and url builtins. It does not require fs, process, module, childprocess, an external package, or a general '' builtin grant. A host HTTPS request rejected an attacker certificate before sandbox execution, then accepted the same certificate and returned an application marker after the sandbox replaced the default CA list. This crosses the intended sandbox boundary. An attacker can make host HTTPS clients trust an attacker-controlled CA, enabling credential theft and response tampering when the attacker can influence a subsequent destination or network path. Replacing…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-98xx-8mx4-x7cm
- Revision 2 · amended ·
Amended from osv record GHSA-98xx-8mx4-x7cm
- Revision 1 · created ·
Published from ghsa record GHSA-98xx-8mx4-x7cm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-92941 Advisory: vm2 NodeVM can replace the host process TLS trust store IDs: CVE-2026-92941, GHSA-98xx-8mx4-x7cm Record: https://patchnext.com/advisories/cve-2026-92941 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vm2: affected >= 3.11.3, <= 3.11.6; fixed in 3.11.7 ## Suggested inspection (read-only) - `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vm2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-98xx-8mx4-x7cm (GitHub-reviewed advisory GHSA-98xx-8mx4-x7cm lists affected ranges: npm vm2 >=3.11.3 <=3.11.6) - Verified: https://osv.dev/vulnerability/GHSA-98xx-8mx4-x7cm (OSV record GHSA-98xx-8mx4-x7cm lists affected ranges: npm vm2 >=3.11.3 <3.11.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…