Skip to content

← Actionable
Critical, CVSS 9.9amended

vm2 crypto builtin loads attacker native code through setEngine

CVE-2026-92939GHSA-46pr-c5wc-xffx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm2 3.11.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vm2

    Affected
    >= 3.11.3, <= 3.11.6
    Fixed in
    3.11.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-92939: 0.62% estimated exploitation activity in the next 30 days; percentile 49.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary vm2 3.11.6 exposes the host crypto module to a NodeVM when that single builtin is allowed. The module is presented through a read-only bridge, but its functions still execute with host-process authority. crypto.setEngine() accepts a filesystem path and asks OpenSSL to dynamically load the referenced native library. An attacker whose untrusted plugin package contains a native library can therefore load that library into the host process by calling crypto.setEngine() from sandboxed JavaScript. The native library's constructor executes before OpenSSL finishes validating whether the file is a usable engine. Consequently, even the expected ERRCRYPTOENGINEUNKNOWN exception occurs only after arbitrary native code has already run. The exploit requires only the crypto builtin. It does not require fs, process, module, childprocess, workerthreads, vm, inspector, unrestricted builtins, or vm2 nesting. Details The vulnerable boundary is the generic builtin loader. Builtins that are not…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-46pr-c5wc-xffx

  2. Revision 2 · amended ·

    Amended from osv record GHSA-46pr-c5wc-xffx

  3. Revision 1 · created ·

    Published from ghsa record GHSA-46pr-c5wc-xffx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-92939

Advisory: vm2 crypto builtin loads attacker native code through setEngine
IDs: CVE-2026-92939, GHSA-46pr-c5wc-xffx
Record: https://patchnext.com/advisories/cve-2026-92939 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm2 3.11.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vm2: affected >= 3.11.3, <= 3.11.6; fixed in 3.11.7

## Suggested inspection (read-only)
- `npm ls vm2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-46pr-c5wc-xffx (GitHub-reviewed advisory GHSA-46pr-c5wc-xffx lists affected ranges: npm vm2 >=3.11.3 <=3.11.6)
- Verified: https://osv.dev/vulnerability/GHSA-46pr-c5wc-xffx (OSV record GHSA-46pr-c5wc-xffx lists affected ranges: npm vm2 >=3.11.3 <3.11.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…