devalue: stringify/uneval serialize shared memory
CVE-2026-92708GHSA-j22f-vq7h-c4qm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (devalue 5.9.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm devalue
- Affected
- >= 5.1.0, <= 5.9.2
- Fixed in
- 5.9.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j22f-vq7h-c4qm lists affected ranges: npm devalue >=5.1.0 <=5.9.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j22f-vq7h-c4qm lists affected ranges: npm devalue >=5.1.0 <5.9.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-92708: 0.73% estimated exploitation activity in the next 30 days; percentile 54.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact stringify and uneval serialize a typed array by emitting its backing ArrayBuffer, not just the view. In the case of a Node Buffer object, the backing buffer is a process-wide shared pool, meaning unrelated memory can be serialized into a response that is then sent to the client. For a Node Buffer the backing store is Node's process-wide shared pool, so serializing a small Buffer copies up to 64 KB of unrelated process memory — including bytes from other in-flight requests — into the output. In an SSR framework (SvelteKit, Nuxt) a public page whose load() returns a 2-byte Buffer, or a small file read with readFileSync, ships another user's request body / Authorization header in its HTML. Unauthenticated, silent, ~43,000× amplification. This is serialization-side, so the parse/unflatten prototype-pollution and DoS guards do not apply — it fires on every SSR render, not only when parsing untrusted input. Workarounds Convert Node Buffer objects to Uint8Array:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-j22f-vq7h-c4qm
- Revision 2 · amended ·
Amended from osv record GHSA-j22f-vq7h-c4qm
- Revision 1 · created ·
Published from ghsa record GHSA-j22f-vq7h-c4qm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-92708 Advisory: devalue: `stringify`/`uneval` serialize shared memory IDs: CVE-2026-92708, GHSA-j22f-vq7h-c4qm Record: https://patchnext.com/advisories/cve-2026-92708 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: devalue 5.9.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm devalue: affected >= 5.1.0, <= 5.9.2; fixed in 5.9.3 ## Suggested inspection (read-only) - `npm ls devalue --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on devalue. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j22f-vq7h-c4qm (GitHub-reviewed advisory GHSA-j22f-vq7h-c4qm lists affected ranges: npm devalue >=5.1.0 <=5.9.2) - Verified: https://osv.dev/vulnerability/GHSA-j22f-vq7h-c4qm (OSV record GHSA-j22f-vq7h-c4qm lists affected ranges: npm devalue >=5.1.0 <5.9.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…