Sulu: JCR-SQL2 injection via categories query parameter (unauthenticated)
CVE-2026-92692GHSA-jg26-q8hg-3pq4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sulu/sulu 3.0.8, 2.6.25), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist sulu/sulu
- Affected
- < 2.6.25>= 3.0.0, < 3.0.8
- Fixed in
- 3.0.8, 2.6.25
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jg26-q8hg-3pq4 lists affected ranges: Packagist sulu/sulu >=0 =3.0.0 <3.0.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jg26-q8hg-3pq4 lists affected ranges: Packagist sulu/sulu >=0 =3.0.0 <3.0.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-92692: 0.42% estimated exploitation activity in the next 30 days; percentile 36.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An unauthenticated JCR-SQL2 injection exists in the Smart Content category filter of the 2.x content query builder. Category IDs supplied through the public ?categories= query parameter are only trimmed and are then concatenated directly into a JCR-SQL2 WHERE clause, without the numeric validation that the equivalent tag filter already performs. Any public page that renders a Smart Content element with category filtering enabled evaluates this parameter, so no authentication or special configuration beyond a category-filtered content block is required. An anonymous visitor can therefore: - inject boolean conditions to infer the existence of, and disclose, content nodes they should not see (for example unpublished pages) via blind boolean-based extraction; and - submit malformed query fragments that cause query errors or resource-intensive queries, degrading availability. Because the sink is a JCR-SQL2 query, the impact is limited to reading and enumerating content-repository…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jg26-q8hg-3pq4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jg26-q8hg-3pq4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-92692 Advisory: Sulu: JCR-SQL2 injection via `categories` query parameter (unauthenticated) IDs: CVE-2026-92692, GHSA-jg26-q8hg-3pq4 Record: https://patchnext.com/advisories/cve-2026-92692 (revision 3, source checked 26 Oct 2026, 14:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sulu/sulu 3.0.8, 2.6.25. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist sulu/sulu: affected < 2.6.25; >= 3.0.0, < 3.0.8; fixed in 3.0.8, 2.6.25 ## Suggested inspection (read-only) - Packagist sulu/sulu: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sulu/sulu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jg26-q8hg-3pq4 (OSV record GHSA-jg26-q8hg-3pq4 lists affected ranges: Packagist sulu/sulu >=0 =3.0.0 <3.0.8 (fixed)) - Verified: https://github.com/advisories/GHSA-jg26-q8hg-3pq4 (GitHub-reviewed advisory GHSA-jg26-q8hg-3pq4 lists affected ranges: Packagist sulu/sulu >=0 =3.0.0 <3.0.8) Commands are suggestions: review each one before running it.
Loading voting…