Skip to content

← Actionable
Critical, CVSS 9.8amended

FriendsOfFlarum OAuth: Unauthenticated account takeover via unverified email trust in Discord OAuth provider

CVE-2026-92161GHSA-g7vj-c29h-3h5m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fof/oauth 2.0.0-beta.4, 1.7.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist fof/oauth

    Affected
    < 1.7.4>= 2.0.0-beta.1, < 2.0.0-beta.4
    Fixed in
    2.0.0-beta.4, 1.7.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-92161: 0.27% estimated exploitation activity in the next 30 days; percentile 19.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An unauthenticated account takeover vulnerability exists in fof/oauth when the Discord OAuth provider is enabled. Discord allows an account to use an unverified email address when its phone number has been verified. During OAuth authentication, Discord may return that email address with "verified": false. Affected versions of fof/oauth did not validate this flag and passed the email address to Flarum core as trusted via provideTrustedEmail(). Flarum core could then match the trusted email address to an existing user, link the attacker-controlled Discord identity to that user, and authenticate the attacker as the victim. An attacker who knows a user's email address can therefore take over the corresponding Flarum account without knowing its password or requiring any interaction from the victim. This includes administrator accounts. Preconditions for exploitation 1. Discord sign-in is enabled on the forum. 2. The victim has a Flarum account with a known email address. 3. The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g7vj-c29h-3h5m

  2. Revision 1 · created ·

    Published from osv record GHSA-g7vj-c29h-3h5m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-92161

Advisory: FriendsOfFlarum OAuth: Unauthenticated account takeover via unverified email trust in Discord OAuth provider
IDs: CVE-2026-92161, GHSA-g7vj-c29h-3h5m
Record: https://patchnext.com/advisories/cve-2026-92161 (revision 2, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fof/oauth 2.0.0-beta.4, 1.7.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist fof/oauth: affected < 1.7.4; >= 2.0.0-beta.1, < 2.0.0-beta.4; fixed in 2.0.0-beta.4, 1.7.4

## Suggested inspection (read-only)
- Packagist fof/oauth: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fof/oauth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g7vj-c29h-3h5m (OSV record GHSA-g7vj-c29h-3h5m lists affected ranges: Packagist fof/oauth >=0 =2.0.0-beta.1 <2.0.0-beta.4 (fixed))
- Verified: https://github.com/advisories/GHSA-g7vj-c29h-3h5m (GitHub-reviewed advisory GHSA-g7vj-c29h-3h5m lists affected ranges: Packagist fof/oauth >=0 =2.0.0-beta.1 <2.0.0-beta.4)

Commands are suggestions: review each one before running it.

Loading voting…