fastify vulnerable to Denial of Service via unhandled exception on HTTP/2 trailer responses
CVE-2026-92081GHSA-4mh8-r7rc-xpvc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastify 5.12.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fastify
- Affected
- < 5.12.5
- Fixed in
- 5.12.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4mh8-r7rc-xpvc lists affected ranges: npm fastify >=0 <5.12.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4mh8-r7rc-xpvc lists affected ranges: npm fastify >=0 <5.12.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-92081: 0.41% estimated exploitation activity in the next 30 days; percentile 35.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact fastify crashes with an uncaught ERRHTTP2INVALIDCONNECTIONHEADERS exception when a route that registers a response trailer via reply.trailer() is served over HTTP/2. Fastify unconditionally adds the Transfer-Encoding: chunked header when a trailer is set, which is forbidden on HTTP/2, so Node.js throws while serializing the response headers. The exception is not caught and becomes an uncaughtException, terminating the Node.js process. One unauthenticated HTTP/2 request to any route that uses trailers is enough to crash the server, dropping all in-flight requests, and the request can be repeated to keep the process down. Applications are affected only when HTTP/2 is enabled (http2: true) and at least one route registers a trailer. HTTP/1.x responses are not affected. Patches Upgrade to fastify 5.12.5 or later. Workarounds Avoid registering response trailers with reply.trailer() on routes served over HTTP/2 until upgrading.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4mh8-r7rc-xpvc
- Revision 2 · amended ·
Amended from osv record GHSA-4mh8-r7rc-xpvc
- Revision 1 · created ·
Published from ghsa record GHSA-4mh8-r7rc-xpvc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-92081 Advisory: fastify vulnerable to Denial of Service via unhandled exception on HTTP/2 trailer responses IDs: CVE-2026-92081, GHSA-4mh8-r7rc-xpvc Record: https://patchnext.com/advisories/cve-2026-92081 (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fastify 5.12.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fastify: affected < 5.12.5; fixed in 5.12.5 ## Suggested inspection (read-only) - `npm ls fastify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fastify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4mh8-r7rc-xpvc (GitHub-reviewed advisory GHSA-4mh8-r7rc-xpvc lists affected ranges: npm fastify >=0 <5.12.5) - Verified: https://osv.dev/vulnerability/GHSA-4mh8-r7rc-xpvc (OSV record GHSA-4mh8-r7rc-xpvc lists affected ranges: npm fastify >=0 <5.12.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…