Langflow: Weak Fernet Key via random.seed()
CVE-2026-9205GHSA-jxw3-mjmx-3pqm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (langflow 1.10.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI langflow
- Affected
- <= 1.10.0
- Fixed in
- 1.10.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jxw3-mjmx-3pqm lists affected ranges: PyPI langflow >=0 <=1.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jxw3-mjmx-3pqm lists affected ranges: PyPI langflow >=0 <1.10.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-9205: 0.30% estimated exploitation activity in the next 30 days; percentile 22.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Langflow uses Python's random module (Mersenne Twister, a non-cryptographic PRNG) seeded with the SECRETKEY to derive the Fernet encryption key for all stored user credentials (API keys, LLM provider secrets, database passwords). When the SECRETKEY is shorter than 32 characters — a common scenario for self-hosted deployments using simple/memorable secrets — the derived encryption key is fully deterministic and reproducible by anyone who knows the seed value. An attacker who obtains the SECRETKEY (e.g., via the MCP path traversal in this repo) can reconstruct the exact Fernet key offline and decrypt every credential stored in the database with no brute force required. Even when SECRETKEY is 32+ characters (the "safe" branch), the raw key material is used directly as the Fernet key — meaning exfiltrating the secretkey file is sufficient to decrypt all credentials without any additional computation. Severity: Critical — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N (9.1) CWE-338:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jxw3-mjmx-3pqm
- Revision 2 · amended ·
Amended from osv record GHSA-jxw3-mjmx-3pqm
- Revision 1 · created ·
Published from ghsa record GHSA-jxw3-mjmx-3pqm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-9205 Advisory: Langflow: Weak Fernet Key via random.seed() IDs: CVE-2026-9205, GHSA-jxw3-mjmx-3pqm Record: https://patchnext.com/advisories/cve-2026-9205 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: langflow 1.10.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI langflow: affected <= 1.10.0; fixed in 1.10.1 ## Suggested inspection (read-only) - `python -m pip show langflow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on langflow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jxw3-mjmx-3pqm (GitHub-reviewed advisory GHSA-jxw3-mjmx-3pqm lists affected ranges: PyPI langflow >=0 <=1.10.0) - Verified: https://osv.dev/vulnerability/GHSA-jxw3-mjmx-3pqm (OSV record GHSA-jxw3-mjmx-3pqm lists affected ranges: PyPI langflow >=0 <1.10.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…