Skip to content

← Actionable
Medium, CVSS 5.9amended

Tornado: CurlAsyncHTTPClient leaks per-request credentials on handle reuse

CVE-2026-91992GHSA-pw6j-qg29-8w7f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tornado 6.5.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tornado

    Affected
    <= 6.5.6
    Fixed in
    6.5.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-91992: 0.24% estimated exploitation activity in the next 30 days; percentile 15.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

CurlAsyncHTTPClient leaks per-request credentials on handle reuse Summary CurlAsyncHTTPClient pools and reuses pycurl handles across requests but does not reset them between requests, and several per-request options are applied with no clearing branch. As a result, sensitive state set by one request persists onto a later request on the same client that does not set it. Two credential vectors are demonstrated below — a client TLS certificate (SSLCERT/SSLKEY) and proxy basic-auth credentials (PROXYUSERPWD) — both leaking to a different, unintended host. This affects all released versions through 6.5.6. Details In tornado/curlhttpclient.py, handles are created once and returned to a free list for reuse (processqueue pops the handle at line 200, finish re-appends it at line 245), and curlsetuprequest is never preceded by curl.reset(). The function clears some carried-over state on the reused handle — unsetopt(PROXYUSERPWD) in the no-proxy branch (line 394), unsetopt(USERPWD) when no auth…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pw6j-qg29-8w7f

  2. Revision 1 · created ·

    Published from osv record GHSA-pw6j-qg29-8w7f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-91992

Advisory: Tornado: CurlAsyncHTTPClient leaks per-request credentials on handle reuse
IDs: CVE-2026-91992, GHSA-pw6j-qg29-8w7f
Record: https://patchnext.com/advisories/cve-2026-91992 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tornado 6.5.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tornado: affected <= 6.5.6; fixed in 6.5.7

## Suggested inspection (read-only)
- `python -m pip show tornado`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tornado.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pw6j-qg29-8w7f (OSV record GHSA-pw6j-qg29-8w7f lists affected ranges: PyPI tornado >=0 <6.5.7 (fixed))
- Verified: https://github.com/advisories/GHSA-pw6j-qg29-8w7f (GitHub-reviewed advisory GHSA-pw6j-qg29-8w7f lists affected ranges: PyPI tornado >=0 <=6.5.6)

Commands are suggestions: review each one before running it.

Loading voting…