Skip to content

← Actionable
High, CVSS 7.1amended

Vikunja: Unbounded CSV row cardinality permits API process termination

CVE-2026-91969GHSA-pqf9-h8g4-8gmh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.vikunja.io/api 2.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-91969: 0.38% estimated exploitation activity in the next 30 days; percentile 31.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unbounded CSV row cardinality permits API process termination Summary The authenticated v2 CSV migration route caps upload bytes but not parsed row cardinality. It reads every record into a [][]string and then materializes a full task object for every row before insertion. Two million one-cell rows fit in a roughly 4 MB multipart request yet exhaust a 512 MiB API process. Impact and affected scope - Type: Resource Exhaustion Csv Import - Affected component: POST /api/v2/migration/csv/migrate - Preconditions: An ordinary authenticated user supplies a multipart CSV containing a very large number of tiny records plus a valid mapping configuration. - Verified revision: 349cd5adbcc831ef08b08e6c9c6d627603c39606 on 28 August 2026 - Affected release range: = 2.5.0; broader historical range not established and maintainer confirmation requested A low-privileged remote user can terminate the API process and deny service to all users with a request far below the configured upload-byte limit.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-pqf9-h8g4-8gmh

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GO-2026-6746

  4. Revision 1 · created ·

    Published from osv record GHSA-pqf9-h8g4-8gmh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-91969

Advisory: Vikunja: Unbounded CSV row cardinality permits API process termination
IDs: CVE-2026-91969, GHSA-pqf9-h8g4-8gmh
Record: https://patchnext.com/advisories/cve-2026-91969 (revision 4, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code.vikunja.io/api 2.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go code.vikunja.io/api: affected >= 2.5.0, <= 2.5.0; fixed in 2.6.0

## Suggested inspection (read-only)
- Go code.vikunja.io/api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code.vikunja.io/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6746 (OSV record GO-2026-6746 lists affected ranges: Go code.vikunja.io/api >=0)
- Verified: https://osv.dev/vulnerability/GHSA-pqf9-h8g4-8gmh (OSV record GHSA-pqf9-h8g4-8gmh lists affected ranges: Go code.vikunja.io/api >=2.5.0 <2.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-pqf9-h8g4-8gmh (GitHub-reviewed advisory GHSA-pqf9-h8g4-8gmh lists affected ranges: Go code.vikunja.io/api >=2.5.0 <=2.5.0)

Commands are suggestions: review each one before running it.

Loading voting…