Skip to content

← Actionable
High, CVSS 7.1amended

Vikunja: Unbounded nested task-filter recursion permits API process termination

CVE-2026-91968GHSA-xxc3-xpmc-vmvr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.vikunja.io/api 2.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-91968: 0.44% estimated exploitation activity in the next 30 days; percentile 37.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unbounded nested task-filter recursion permits API process termination Summary Authenticated task-list routes accept a filter expression without a length or nesting-depth bound, preprocess it, parse it recursively through fexpr, and recursively convert the resulting expression tree. A syntactically valid deeply nested expression well below the HTTP request-size ceiling exhausts memory and kills the API process. Impact and affected scope - Type: Resource Exhaustion Recursive Parser - Affected component: GET /api/v2/projects/{project}/tasks?filter=<nested expression; Other authenticated task-collection entrypoints that share getTaskFiltersFromFilterString - Preconditions: A low-privileged authenticated user supplies thousands of balanced parentheses around a valid task predicate in the filter query parameter. - Verified revision: 349cd5adbcc831ef08b08e6c9c6d627603c39606 on 28 August 2026 - Affected release range: = 2.5.0; broader historical range not established and maintainer…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-xxc3-xpmc-vmvr

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GO-2026-6759

  4. Revision 1 · created ·

    Published from osv record GHSA-xxc3-xpmc-vmvr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-91968

Advisory: Vikunja: Unbounded nested task-filter recursion permits API process termination
IDs: CVE-2026-91968, GHSA-xxc3-xpmc-vmvr
Record: https://patchnext.com/advisories/cve-2026-91968 (revision 4, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: code.vikunja.io/api 2.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go code.vikunja.io/api: affected >= 2.5.0, <= 2.5.0; fixed in 2.6.0

## Suggested inspection (read-only)
- Go code.vikunja.io/api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on code.vikunja.io/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6759 (OSV record GO-2026-6759 lists affected ranges: Go code.vikunja.io/api >=0)
- Verified: https://osv.dev/vulnerability/GHSA-xxc3-xpmc-vmvr (OSV record GHSA-xxc3-xpmc-vmvr lists affected ranges: Go code.vikunja.io/api >=2.5.0 <2.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-xxc3-xpmc-vmvr (GitHub-reviewed advisory GHSA-xxc3-xpmc-vmvr lists affected ranges: Go code.vikunja.io/api >=2.5.0 <=2.5.0)

Commands are suggestions: review each one before running it.

Loading voting…