Skip to content

← Actionable
Critical, CVSS 9.3amended

Home Assistant: XSS in Statistics Graph Card

CVE-2026-91130GHSA-wx4m-69m9-gx3m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (homeassistant 2026.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-91130: 0.48% estimated exploitation activity in the next 30 days; percentile 41.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An authenticated party can add a malicious name to any statistics-capable entity, allowing for Cross-Site Scripting attacks against anyone who views a Statistics Graph card containing that entity, when they hover over any data point on the chart. Payload <img width="1529" height="441" alt="image" src="https://github.com/user-attachments/assets/6926ce53-75fb-455a-bd4e-0c5281e8bed8" / Payload triggering <img width="835" height="469" alt="image" src="https://github.com/user-attachments/assets/0bb9d17a-c123-4d44-8471-35097f65ddd2" / An alternative, and more impactful scenario, is that the entity gets a malicious name from the provider of the integration (e.g. Tibber, Shelly, or any HACS integration), and is exploited that way through the default name — without requiring any direct access to the Home Assistant instance. This is the same supply-chain vector as CVE-2025-62172. Details The Statistics Graph card renders entity names in ECharts tooltips as raw HTML. The offending line…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-wx4m-69m9-gx3m

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-wx4m-69m9-gx3m

  4. Revision 1 · created ·

    Published from ghsa record GHSA-wx4m-69m9-gx3m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-91130

Advisory: Home Assistant: XSS in Statistics Graph Card
IDs: CVE-2026-91130, GHSA-wx4m-69m9-gx3m
Record: https://patchnext.com/advisories/cve-2026-91130 (revision 4, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: homeassistant 2026.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI homeassistant: affected < 2026.7.0; fixed in 2026.7.0

## Suggested inspection (read-only)
- `python -m pip show homeassistant`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on homeassistant.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wx4m-69m9-gx3m (GitHub-reviewed advisory GHSA-wx4m-69m9-gx3m lists affected ranges: PyPI homeassistant >=0 <2026.7.0)
- Verified: https://osv.dev/vulnerability/GHSA-wx4m-69m9-gx3m (OSV record GHSA-wx4m-69m9-gx3m lists affected ranges: PyPI homeassistant >=0 <2026.7.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…