Drupal Core has a SQL Injection issue
CVE-2026-9082GHSA-ghwc-95x2-682j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 11.3.10, 11.2.12, 11.1.10, 10.6.9, 10.5.10, 10.4.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/core
- Affected
- >= 8.9.0, < 10.4.10>= 10.5.0, < 10.5.10>= 10.6.0, < 10.6.9>= 11.0.0, < 11.1.10>= 11.2.0, < 11.2.12>= 11.3.0, < 11.3.10
- Fixed in
- 10.6.9, 10.5.10, 11.3.10, 11.2.12, 11.1.10, 10.4.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ghwc-95x2-682j lists affected ranges: Packagist drupal/core >=8.9.0 =10.5.0 =10.6.0 =11.0.0 =11.2.0 =11.3.0 <11.3.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2026-9082 to the Known Exploited Vulnerabilities catalog on 2026-05-22.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2026-05-22).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-9082: 89.38% estimated exploitation activity in the next 30 days; percentile 99.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Drupal Drupal core allows SQL Injection. This issue affects Drupal core: from 8.9.0 before 10.4.10, from 10.5.0 before 10.5.10, from 10.6.0 before 10.6.9, from 11.0.0 before 11.1.10, from 11.2.0 before 11.2.12, from 11.3.0 before 11.3.10.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ghwc-95x2-682j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-9082 Advisory: Drupal Core has a SQL Injection issue IDs: CVE-2026-9082, GHSA-ghwc-95x2-682j Record: https://patchnext.com/advisories/cve-2026-9082 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: drupal/core 11.3.10, 11.2.12, 11.1.10, 10.6.9, 10.5.10, 10.4.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/core: affected >= 8.9.0, < 10.4.10; >= 10.5.0, < 10.5.10; >= 10.6.0, < 10.6.9; >= 11.0.0, < 11.1.10; >= 11.2.0, < 11.2.12; >= 11.3.0, < 11.3.10; fixed in 10.6.9, 10.5.10, 11.3.10, 11.2.12, 11.1.10, 10.4.10 ## Suggested inspection (read-only) - Packagist drupal/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ghwc-95x2-682j (GitHub-reviewed advisory GHSA-ghwc-95x2-682j lists affected ranges: Packagist drupal/core >=8.9.0 =10.5.0 =10.6.0 =11.0.0 =11.2.0 =11.3.0 <11.3.10) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2026-9082 to the Known Exploited Vulnerabilities catalog on 2026-05-22.) Commands are suggestions: review each one before running it.
Loading voting…