Apache CouchDB: Auth bypass in prefixed _users and _replicator databases
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (couchdb 3.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami couchdb
- Affected
- < 3.5.3
- Fixed in
- 3.5.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-couchdb-2026-90800 lists affected ranges: Bitnami couchdb >=0 <3.5.3 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:N/AU:Y/R:U/V:C/RE:M/U:Amber · score source
- EPSS
- CVE-2026-90800: 0.63% estimated exploitation activity in the next 30 days; percentile 50.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Missing authorisation checks in chttpd in Apache CouchDB 3.5.2 and below on all platforms allows any request to read the full contents of a prefixed _user or _replicator database via an unauthorised API endpoint. The use of prefixed system databases is very rare. Users are recommended to upgrade to version 3.5.3, which fixes this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record BIT-couchdb-2026-90800
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-90800 Advisory: Apache CouchDB: Auth bypass in prefixed _users and _replicator databases IDs: CVE-2026-90800 Record: https://patchnext.com/advisories/cve-2026-90800 (revision 1, source checked 30 Oct 2026, 07:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: couchdb 3.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami couchdb: affected < 3.5.3; fixed in 3.5.3 ## Suggested inspection (read-only) - Bitnami couchdb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on couchdb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/BIT-couchdb-2026-90800 (OSV record BIT-couchdb-2026-90800 lists affected ranges: Bitnami couchdb >=0 <3.5.3 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…