Skip to content

← Actionable
High, CVSS 7.5amended

Nodemailer addressparser: O(n^2) on comment-joined addresses enables a remote DoS (reachable via mailparser)

CVE-2026-90776GHSA-prgh-xp8r-p3m5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodemailer 10.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm nodemailer

    Affected
    >= 9.1.0, <= 10.0.4
    Fixed in
    10.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-90776: 0.68% estimated exploitation activity in the next 30 days; percentile 52.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary nodemailer/lib/addressparser parses one shape of address in O(n^2) time. A single ~640 KB address value blocks the Node.js event loop for roughly 7 seconds. And it is reachable without auth: mailparser feeds inbound email headers straight into this parser, so one crafted email is enough to stall a service that parses mail. Details The parser builds a single address by accumulating its atoms into one string. When the atoms are separated by RFC 5322 comments, like a@b(c)@b(c)@b(c)..., every atom re-joins that same growing string. The join check in src/addressparser/index.ts: The issue is the order of the last two operands. parts[parts.length - 1].slice(-1) runs before the cheap token.value.charAt(0). slice(-1) has to flatten the accumulator to read its last character → O(current length) → and that runs on every token → O(n^2) over the whole value. Since || is left to right, the cheap charAt(0) that would short-circuit never gets the chance. The chain: long comment-joined…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-prgh-xp8r-p3m5

  2. Revision 2 · amended ·

    Amended from osv record GHSA-prgh-xp8r-p3m5

  3. Revision 1 · created ·

    Published from ghsa record GHSA-prgh-xp8r-p3m5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-90776

Advisory: Nodemailer addressparser: O(n^2) on comment-joined addresses enables a remote DoS (reachable via mailparser)
IDs: CVE-2026-90776, GHSA-prgh-xp8r-p3m5
Record: https://patchnext.com/advisories/cve-2026-90776 (revision 3, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nodemailer 10.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm nodemailer: affected >= 9.1.0, <= 10.0.4; fixed in 10.0.5

## Suggested inspection (read-only)
- `npm ls nodemailer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nodemailer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-prgh-xp8r-p3m5 (GitHub-reviewed advisory GHSA-prgh-xp8r-p3m5 lists affected ranges: npm nodemailer >=9.1.0 <=10.0.4)
- Verified: https://osv.dev/vulnerability/GHSA-prgh-xp8r-p3m5 (OSV record GHSA-prgh-xp8r-p3m5 lists affected ranges: npm nodemailer >=9.1.0 <10.0.5 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…