joi messages compilation allows prototype replacement through __proto__ error codes
CVE-2026-90771GHSA-wr44-6hxh-3jwq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (joi 18.2.9, 17.13.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm joi
- Affected
- < 17.13.8>= 18.0.0, < 18.2.9
- Fixed in
- 17.13.8, 18.2.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wr44-6hxh-3jwq lists affected ranges: npm joi >=0 =18.0.0 <18.2.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wr44-6hxh-3jwq lists affected ranges: npm joi >=0 =18.0.0 <18.2.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-90771: 0.39% estimated exploitation activity in the next 30 days; percentile 33.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
joi before versions 17.13.8 and 18.2.9 contains a prototype pollution vulnerability in the messages compilation function that accepts proto as an error code. Attackers can supply proto keys in custom messages to replace the returned object's prototype, breaking downstream code relying on Object.prototype methods.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-wr44-6hxh-3jwq
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-wr44-6hxh-3jwq
- Revision 1 · created ·
Published from ghsa record GHSA-wr44-6hxh-3jwq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-90771 Advisory: joi messages compilation allows prototype replacement through __proto__ error codes IDs: CVE-2026-90771, GHSA-wr44-6hxh-3jwq Record: https://patchnext.com/advisories/cve-2026-90771 (revision 4, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: joi 18.2.9, 17.13.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm joi: affected < 17.13.8; >= 18.0.0, < 18.2.9; fixed in 17.13.8, 18.2.9 ## Suggested inspection (read-only) - `npm ls joi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on joi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wr44-6hxh-3jwq (GitHub-reviewed advisory GHSA-wr44-6hxh-3jwq lists affected ranges: npm joi >=0 =18.0.0 <18.2.9) - Verified: https://osv.dev/vulnerability/GHSA-wr44-6hxh-3jwq (OSV record GHSA-wr44-6hxh-3jwq lists affected ranges: npm joi >=0 =18.0.0 <18.2.9 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…